=========================================================================Ubuntu Security Notice USN-6232-1
July 20, 2023

wkhtmltopdf vulnerability
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS (Available with Ubuntu Pro)
- Ubuntu 16.04 LTS (Available with Ubuntu Pro)
- Ubuntu 14.04 LTS (Available with Ubuntu Pro)

Summary:

wkhtmltopdf could be made to expose sensitive information if it opened a
specially crafted file.

Software Description:
- wkhtmltopdf: Command line utility to convert html to pdf using WebKit

Details:

It was discovered that wkhtmltopdf was not properly enforcing the
same-origin policy when processing certain HTML files. If a user or
automated system using wkhtmltopdf were tricked into processing a
specially crafted HTML file, an attacker could possibly use this issue to
expose sensitive information.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
wkhtmltopdf 0.12.5-1ubuntu0.1

Ubuntu 18.04 LTS (Available with Ubuntu Pro):
wkhtmltopdf 0.12.4-1ubuntu0.1~esm1

Ubuntu 16.04 LTS (Available with Ubuntu Pro):
wkhtmltopdf 0.12.2.4-1ubuntu0.1~esm1

Ubuntu 14.04 LTS (Available with Ubuntu Pro):
wkhtmltopdf 0.9.9-4ubuntu0.1~esm1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6232-1
CVE-2020-21365

Package Information:
https://launchpad.net/ubuntu/+source/wkhtmltopdf/0.12.5-1ubuntu0.1

Ubuntu 6232-1: wkhtmltopdf vulnerability

July 20, 2023
wkhtmltopdf could be made to expose sensitive information if it opened a specially crafted file.

Summary

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 20.04 LTS: wkhtmltopdf 0.12.5-1ubuntu0.1 Ubuntu 18.04 LTS (Available with Ubuntu Pro): wkhtmltopdf 0.12.4-1ubuntu0.1~esm1 Ubuntu 16.04 LTS (Available with Ubuntu Pro): wkhtmltopdf 0.12.2.4-1ubuntu0.1~esm1 Ubuntu 14.04 LTS (Available with Ubuntu Pro): wkhtmltopdf 0.9.9-4ubuntu0.1~esm1 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-6232-1

CVE-2020-21365

Severity
July 20, 2023

Package Information

https://launchpad.net/ubuntu/+source/wkhtmltopdf/0.12.5-1ubuntu0.1

Feedback