==========================================================================
Ubuntu Security Notice USN-6580-1
January 15, 2024

w3m vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.10
- Ubuntu 23.04
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS (Available with Ubuntu Pro)
- Ubuntu 14.04 LTS (Available with Ubuntu Pro)

Summary:

w3m could be made to crash or run programs as your login if it opened a malicious website.

Software Description:
- w3m: WWW browsable pager with excellent tables/frames support

Details:

It was discovered that w3m incorrectly handled certain HTML files.
An attacker could possibly use this issue to cause a crash or
execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.10:
  w3m                             0.5.3+git20230121-2ubuntu0.23.10.1

Ubuntu 23.04:
  w3m                             0.5.3+git20230121-2ubuntu0.23.04.1

Ubuntu 22.04 LTS:
  w3m                             0.5.3+git20210102-6ubuntu0.2

Ubuntu 20.04 LTS:
  w3m                             0.5.3-37ubuntu0.2

Ubuntu 18.04 LTS (Available with Ubuntu Pro):
  w3m                             0.5.3-36ubuntu0.1+esm1

Ubuntu 14.04 LTS (Available with Ubuntu Pro):
  w3m                             0.5.3-15ubuntu0.2+esm2

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-6580-1
  CVE-2023-4255

Package Information:
  https://launchpad.net/ubuntu/+source/w3m/0.5.3+git20230121-2ubuntu0.23.10.1
  https://launchpad.net/ubuntu/+source/w3m/0.5.3+git20230121-2ubuntu0.23.04.1
  https://launchpad.net/ubuntu/+source/w3m/0.5.3+git20210102-6ubuntu0.2
  https://launchpad.net/ubuntu/+source/w3m/0.5.3-37ubuntu0.2

Ubuntu 6580-1: w3m vulnerability

January 15, 2024
w3m could be made to crash or run programs as your login if it opened a malicious website.

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 23.10 - Ubuntu 23.04 - Ubuntu 22.04 LTS - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS (Available with Ubuntu Pro) - Ubuntu 14.04 LTS (Available with Ubuntu Pro) Summary: w3m could be made to crash or run programs as your login if it opened a malicious website. Software Description: - w3m: WWW browsable pager with excellent tables/frames support Details: It was discovered that w3m incorrectly handled certain HTML files. An attacker could possibly use this issue to cause a crash or execute arbitrary code.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 23.10: w3m 0.5.3+git20230121-2ubuntu0.23.10.1 Ubuntu 23.04: w3m 0.5.3+git20230121-2ubuntu0.23.04.1 Ubuntu 22.04 LTS: w3m 0.5.3+git20210102-6ubuntu0.2 Ubuntu 20.04 LTS: w3m 0.5.3-37ubuntu0.2 Ubuntu 18.04 LTS (Available with Ubuntu Pro): w3m 0.5.3-36ubuntu0.1+esm1 Ubuntu 14.04 LTS (Available with Ubuntu Pro): w3m 0.5.3-15ubuntu0.2+esm2 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-6580-1

CVE-2023-4255

Severity
Ubuntu Security Notice USN-6580-1

Package Information

https://launchpad.net/ubuntu/+source/w3m/0.5.3+git20230121-2ubuntu0.23.10.1 https://launchpad.net/ubuntu/+source/w3m/0.5.3+git20230121-2ubuntu0.23.04.1 https://launchpad.net/ubuntu/+source/w3m/0.5.3+git20210102-6ubuntu0.2 https://launchpad.net/ubuntu/+source/w3m/0.5.3-37ubuntu0.2

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo