Discover Government News

==========================================================================
Ubuntu Security Notice USN-6674-1
March 04, 2024

python-django vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

Django could be made to consume resources or crash if it received specially
crafted network traffic.

Software Description:
- python-django: High-level Python web development framework

Details:

Seokchan Yoon discovered that the Django Truncator function incorrectly
handled very long HTML input. A remote attacker could possibly use this
issue to cause Django to consume resources, leading to a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.10:
   python3-django                  3:4.2.4-1ubuntu2.2

Ubuntu 22.04 LTS:
   python3-django                  2:3.2.12-2ubuntu1.11

Ubuntu 20.04 LTS:
   python3-django                  2:2.2.12-1ubuntu0.22

In general, a standard system update will make all the necessary changes.

References:
   https://ubuntu.com/security/notices/USN-6674-1
   CVE-2024-27351

Package Information:
   https://launchpad.net/ubuntu/+source/python-django/3:4.2.4-1ubuntu2.2
   https://launchpad.net/ubuntu/+source/python-django/2:3.2.12-2ubuntu1.11
   https://launchpad.net/ubuntu/+source/python-django/2:2.2.12-1ubuntu0.22

Ubuntu 6674-1: Django vulnerability

March 4, 2024
Django could be made to consume resources or crash if it received specially crafted network traffic.

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 23.10 - Ubuntu 22.04 LTS - Ubuntu 20.04 LTS Summary: Django could be made to consume resources or crash if it received specially crafted network traffic. Software Description: - python-django: High-level Python web development framework Details: Seokchan Yoon discovered that the Django Truncator function incorrectly handled very long HTML input. A remote attacker could possibly use this issue to cause Django to consume resources, leading to a denial of service.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 23.10: python3-django 3:4.2.4-1ubuntu2.2 Ubuntu 22.04 LTS: python3-django 2:3.2.12-2ubuntu1.11 Ubuntu 20.04 LTS: python3-django 2:2.2.12-1ubuntu0.22 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-6674-1

CVE-2024-27351

Severity
Ubuntu Security Notice USN-6674-1

Package Information

https://launchpad.net/ubuntu/+source/python-django/3:4.2.4-1ubuntu2.2 https://launchpad.net/ubuntu/+source/python-django/2:3.2.12-2ubuntu1.11 https://launchpad.net/ubuntu/+source/python-django/2:2.2.12-1ubuntu0.22

Related News