Linux Security
Linux Security
Linux Security

ArchLinux: 201804-4: apache: multiple issues

Date 12 Apr 2018
2095
Posted By Anthony Pell
The package apache before version 2.4.33-1 is vulnerable to multiple issues including session hijacking, access restriction bypass, content spoofing and denial of service.
Arch Linux Security Advisory ASA-201804-4
=========================================

Severity: Medium
Date    : 2018-04-04
CVE-ID  : CVE-2017-15710 CVE-2017-15715 CVE-2018-1283 CVE-2018-1301
          CVE-2018-1302 CVE-2018-1303 CVE-2018-1312
Package : apache
Type    : multiple issues
Remote  : Yes
Link    : https://security.archlinux.org/AVG-664

Summary
=======

The package apache before version 2.4.33-1 is vulnerable to multiple
issues including session hijacking, access restriction bypass, content
spoofing and denial of service.

Resolution
==========

Upgrade to 2.4.33-1.

# pacman -Syu "apache>=2.4.33-1"

The problems have been fixed upstream in version 2.4.33.

Workaround
==========

None.

Description
===========

- CVE-2017-15710 (denial of service)

In Apache httpd 2.0.23 to 2.0.65, 2.2.0 to 2.2.34, and 2.4.0 to 2.4.29,
mod_authnz_ldap, if configured with AuthLDAPCharsetConfig, uses the
Accept-Language header value to lookup the right charset encoding when
verifying the user's credentials. If the header value is not present in
the charset conversion table, a fallback mechanism is used to truncate
it to a two characters value to allow a quick retry (for example, 'en-
US' is truncated to 'en'). A header value of less than two characters
forces an out of bound write of one NUL byte to a memory location that
is not part of the string. In the worst case, quite unlikely, the
process would crash which could be used as a Denial of Service attack.
In the more likely case, this memory is already reserved for future use
and the issue has no effect at all.

- CVE-2017-15715 (access restriction bypass)

In Apache httpd 2.4.0 before 2.4.30, the expression specified in
 could match '$' to a newline character in a malicious
filename, rather than matching only the end of the filename. This could
be exploited in environments where uploads of some files are externally
blocked, but only by matching the trailing portion of the filename.

- CVE-2018-1283 (session hijacking)

In Apache httpd 2.2.0 before 2.4.30, when mod_session is configured to
forward its session data to CGI applications (SessionEnv on, not the
default), a remote user may influence their content by using a
"Session" header. This comes from the "HTTP_SESSION" variable name used
by mod_session to forward its data to CGIs, since the prefix "HTTP_" is
also used by the Apache HTTP Server to pass HTTP header fields, per CGI
specifications.

- CVE-2018-1301 (denial of service)

A specially crafted request could have crashed the Apache HTTP Server
prior to version 2.4.30, due to an out of bound access after a size
limit is reached by reading the HTTP header. This vulnerability is
considered very hard if not impossible to trigger in non-debug mode
(both log and build level), so it is classified as low risk for common
server usage.

- CVE-2018-1302 (denial of service)

When an HTTP/2 stream was destroyed after being handled, the Apache
HTTP Server prior to version 2.4.30 could have written a NULL pointer
potentially to an already freed memory. The memory pools maintained by
the server make this vulnerability hard to trigger in usual
configurations, the reporter and the team could not reproduce it
outside debug builds, so it is classified as low risk.

- CVE-2018-1303 (denial of service)

A specially crafted HTTP request header could have crashed the Apache
HTTP Server prior to version 2.4.30 due to an out of bound read while
preparing data to be cached in shared memory. It could be used as a
Denial of Service attack against users of mod_cache_socache.

- CVE-2018-1312 (content spoofing)

In Apache httpd 2.2.0 before 2.4.30, when generating an HTTP Digest
authentication challenge, the nonce sent to prevent reply attacks was
not correctly generated using a pseudo-random seed. In a cluster of
servers using a common Digest authentication configuration, HTTP
requests could be replayed across servers by an attacker without
detection.

Impact
======

A remote attacker is able to crash a server, hijack a user session,
upload arbitrary files or spoof requests by providing a crafted
request.

References
==========

https://httpd.apache.org/security/vulnerabilities_24.html
https://security.archlinux.org/CVE-2017-15710
https://security.archlinux.org/CVE-2017-15715
https://security.archlinux.org/CVE-2018-1283
https://security.archlinux.org/CVE-2018-1301
https://security.archlinux.org/CVE-2018-1302
https://security.archlinux.org/CVE-2018-1303
https://security.archlinux.org/CVE-2018-1312

Advisories

LinuxSecurity Poll

How frequently do you patch/update your system?

No answer selected. Please try again.
Please select either existing option or enter your own, however not both.
Please select minimum 0 answer(s) and maximum 3 answer(s).
/main-polls/52-how-frequently-do-you-patch-update-your-system?task=poll.vote&format=json
52
radio
[{"id":"179","title":"As soon as patches\/updates are released - I track advisories for my distro(s) diligently","votes":"66","type":"x","order":"1","pct":75.86,"resources":[]},{"id":"180","title":"Every so often, when I think of it","votes":"14","type":"x","order":"2","pct":16.09,"resources":[]},{"id":"181","title":"Hardly ever","votes":"7","type":"x","order":"3","pct":8.05,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350

Please vote first in order to view vote results.

VOTE ON THE POLL PAGE


VIEW MORE POLLS

bottom 200

Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript![ ? ]

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.