Linux Security
    Linux Security
    Linux Security

    ArchLinux: 202006-5: tomcat8: arbitrary code execution

    Date
    147
    Posted By
    The package tomcat8 before version 8.5.55-1 is vulnerable to arbitrary code execution.
    Arch Linux Security Advisory ASA-202006-5
    =========================================
    
    Severity: High
    Date    : 2020-06-06
    CVE-ID  : CVE-2020-9484
    Package : tomcat8
    Type    : arbitrary code execution
    Remote  : Yes
    Link    : https://security.archlinux.org/AVG-1170
    
    Summary
    =======
    
    The package tomcat8 before version 8.5.55-1 is vulnerable to arbitrary
    code execution.
    
    Resolution
    ==========
    
    Upgrade to 8.5.55-1.
    
    # pacman -Syu "tomcat8>=8.5.55-1"
    
    The problem has been fixed upstream in version 8.5.55.
    
    Workaround
    ==========
    
    None.
    
    Description
    ===========
    
    When using Apache Tomcat versions 10.0.0-M1 to 10.0.0-M4, 9.0.0.M1 to
    9.0.34, 8.5.0 to 8.5.54 and 7.0.0 to 7.0.103 if: a) an attacker is able
    to control the contents and name of a file on the server; and b) the
    server is configured to use the PersistenceManager with a FileStore;
    and c) the PersistenceManager is configured with
    sessionAttributeValueClassNameFilter="null" (the default unless a
    SecurityManager is used) or a sufficiently lax filter to allow the
    attacker provided object to be deserialized; and d) the attacker knows
    the relative file path from the storage location used by FileStore to
    the file the attacker has control over; then, using a specifically
    crafted request, the attacker will be able to trigger remote code
    execution via deserialization of the file under their control.
    
    Note that all of conditions a) to d) must be true for the attack to
    succeed.
    
    Impact
    ======
    
    A remote attacker can execute code on the affected host if they control
    the file content and know the path.
    
    References
    ==========
    
    https://lists.apache.org/thread.html/r77eae567ed829da9012cadb29af17f2df8fa23bf66faf88229857bb1%40%3Cannounce.tomcat.apache.org%3E
    https://security.archlinux.org/CVE-2020-9484
    

    LinuxSecurity Poll

    I agree with Linus Torvalds - Apple's new M1-powered laptops should run on Linux.

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 2 answer(s).
    /main-polls/45-i-agree-with-linus-torvalds-apple-s-new-m1-powered-laptops-should-run-on-linux?task=poll.vote&format=json
    45
    radio
    [{"id":"158","title":"True","votes":"8","type":"x","order":"1","pct":100,"resources":[]},{"id":"159","title":"False","votes":"0","type":"x","order":"2","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350

    Please vote first in order to view vote results.


    VIEW MORE POLLS

    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.