Arch Linux Security Advisory ASA-202107-8
=========================================

Severity: Medium
Date    : 2021-07-01
CVE-ID  : CVE-2021-27021
Package : puppet
Type    : privilege escalation
Remote  : Yes
Link    : https://security.archlinux.org/AVG-2105

Summary
=======

The package puppet before version 6.23.0-1 is vulnerable to privilege
escalation.

Resolution
==========

Upgrade to 6.23.0-1.

# pacman -Syu "puppet>=6.23.0-1"

The problem has been fixed upstream in version 6.23.0.

Workaround
==========

None.

Description
===========

A flaw was discovered in Puppet DB, this flaw results in an escalation
of privileges which allows the user to delete tables via an SQL query.
This has been resolved in Puppet DB 6.17.0, 7.4.1, Platform 6.23, 7.7.0
and Puppet Enterprise 2021.2, 2019.8.7.

Impact
======

A privilege escalation security issue allowed users to delete tables.

References
==========

https://puppet.com/security/cve/cve-2021-27021/
https://puppet.com/docs/puppetdb/6/release_notes.html#puppetdb-6170
https://tickets.puppetlabs.com/browse/PDB-5138
https://github.com/puppetlabs/puppetdb/commit/c146e624d230f7410fb648d58ae28c0e3cd457a2
https://github.com/puppetlabs/puppetdb/commit/f8dc81678cf347739838e42cc1c426d96406c266
https://github.com/puppetlabs/puppetdb/commit/72bd137511487643a3a6236ad9e72a5dd4a6fadb
https://security.archlinux.org/CVE-2021-27021