- -------------------------------------------------------------------------
Debian Security Advisory DSA-4588-1                   [email protected]
https://www.debian.org/security/                       Sebastien Delafond
December 17, 2019                     https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : python-ecdsa
CVE ID         : CVE-2019-14853 CVE-2019-14859

It was discovered that python-ecdsa, a cryptographic signature library
for Python, incorrectly handled certain signatures. A remote attacker
could use this issue to cause python-ecdsa to either not warn about
incorrect signatures, or generate exceptions resulting in a
denial-of-service.

For the oldstable distribution (stretch), these problems have been fixed
in version 0.13-2+deb9u1.

For the stable distribution (buster), these problems have been fixed in
version 0.13-3+deb10u1.

We recommend that you upgrade your python-ecdsa packages.

For the detailed security status of python-ecdsa please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/python-ecdsa

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]