- -------------------------------------------------------------------------
Debian Security Advisory DSA-4739-1                   security@debian.org
https://www.debian.org/security/                           Alberto Garcia
August 03, 2020                       https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : webkit2gtk
CVE ID         : CVE-2020-9862 CVE-2020-9893 CVE-2020-9894 CVE-2020-9895
                 CVE-2020-9915 CVE-2020-9925

The following vulnerabilities have been discovered in the webkit2gtk
web engine:

CVE-2020-9862

    Ophir Lojkine discovered that copying a URL from the Web Inspector
    may lead to command injection.

CVE-2020-9893

    0011 discovered that a remote attacker may be able to cause
    unexpected application termination or arbitrary code execution.

CVE-2020-9894

    0011 discovered that a remote attacker may be able to cause
    unexpected application termination or arbitrary code execution.

CVE-2020-9895

    Wen Xu discovered that a remote attacker may be able to cause
    unexpected application termination or arbitrary code execution.

CVE-2020-9915

    Ayoub Ait Elmokhtar discovered that processing maliciously crafted
    web content may prevent Content Security Policy from being
    enforced.

CVE-2020-9925

    An anonymous researcher discovered that processing maliciously
    crafted web content may lead to universal cross site scripting.

For the stable distribution (buster), these problems have been fixed in
version 2.28.4-1~deb10u1.

We recommend that you upgrade your webkit2gtk packages.

For the detailed security status of webkit2gtk please refer to its
security tracker page at:
https://security-tracker.debian.org/tracker/source-package/webkit2gtk

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org

Debian: DSA-4739-1: webkit2gtk security update

August 3, 2020
The following vulnerabilities have been discovered in the webkit2gtk web engine: CVE-2020-9862

Summary

CVE-2020-9862

Ophir Lojkine discovered that copying a URL from the Web Inspector
may lead to command injection.

CVE-2020-9893

0011 discovered that a remote attacker may be able to cause
unexpected application termination or arbitrary code execution.

CVE-2020-9894

0011 discovered that a remote attacker may be able to cause
unexpected application termination or arbitrary code execution.

CVE-2020-9895

Wen Xu discovered that a remote attacker may be able to cause
unexpected application termination or arbitrary code execution.

CVE-2020-9915

Ayoub Ait Elmokhtar discovered that processing maliciously crafted
web content may prevent Content Security Policy from being
enforced.

CVE-2020-9925

An anonymous researcher discovered that processing maliciously
crafted web content may lead to universal cross site scripting.

For the stable distribution (buster), these problems have been fixed in
version 2.28.4-1~deb10u1.

We recommend that you upgrade your webkit2gtk packages.

For the detailed security status of webkit2gtk please refer to its
security tracker page at:
https://security-tracker.debian.org/tracker/source-package/webkit2gtk

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org

Severity
Package : webkit2gtk
CVE ID : CVE-2020-9862 CVE-2020-9893 CVE-2020-9894 CVE-2020-9895

Related News