-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-5717-1                   security@debian.org
https://www.debian.org/security/                       Moritz Muehlenhoff
June 20, 2024                         https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : php8.2
CVE ID         : CVE-2024-5458

It was discovered that user validation was incorrectly implemented
for filter_var(FILTER_VALIDATE_URL).

For the stable distribution (bookworm), this problem has been fixed in
version 8.2.20-1~deb12u1.

We recommend that you upgrade your php8.2 packages.

For the detailed security status of php8.2 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/php8.2

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org

Debian: DSA-5717-1: php8.2 Security Advisory Updates

June 20, 2024
It was discovered that user validation was incorrectly implemented for filter_var(FILTER_VALIDATE_URL)

Summary

It was discovered that user validation was incorrectly implemented
for filter_var(FILTER_VALIDATE_URL).

For the stable distribution (bookworm), this problem has been fixed in
version 8.2.20-1~deb12u1.

We recommend that you upgrade your php8.2 packages.

For the detailed security status of php8.2 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/php8.2

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/



Severity
Package : php8.2
CVE ID : CVE-2024-5458

Related News