- -----------------------------------------------------------------------
Debian LTS Advisory DLA-2549-1              [email protected]
https://www.debian.org/lts/security/                      Utkarsh Gupta
February 08, 2021                           https://wiki.debian.org/LTS
- -----------------------------------------------------------------------

Package        : gdisk
Version        : 1.0.1-1+deb9u1
CVE ID         : CVE-2020-0256 CVE-2021-0308

CVE-2020-0256

    In LoadPartitionTable of gpt.cc, there is a possible
    out of bounds write due to a missing bounds check. This
    could lead to local escalation of privilege with no
    additional execution privileges needed.

CVE-2021-0308

    In ReadLogicalParts of basicmbr.cc, there is a possible
    out of bounds write due to a missing bounds check. This
    could lead to local escalation of privilege with no
    additional execution privileges needed.

For Debian 9 stretch, these problems have been fixed in version
1.0.1-1+deb9u1.

We recommend that you upgrade your gdisk packages.

For the detailed security status of gdisk please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/gdisk

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS