- -------------------------------------------------------------------------
Debian LTS Advisory DLA-2587-1                [email protected]
https://www.debian.org/lts/security/                          Abhijith PA
March 09, 2021                                https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : privoxy
Version        : 3.0.26-3+deb9u2
CVE ID         : CVE-2021-20272 CVE-2021-20273 CVE-2021-20275 
                 CVE-2021-20276

Multiple vulnerabilites were discovered in privoxy, a web proxy with 
advanced filtering capabilities.

CVE-2021-20272

    An assertion failure could be triggered with a crafted CGI 
    request leading to server crash.

CVE-2021-20273

    A crash can occur via a crafted CGI request if Privoxy is toggled 
    off.

CVE-2021-20275

     An invalid read of size two may occur in 
     chunked_body_is_complete() leading to denial of service.

CVE-2021-20276

    Invalid memory access with an invalid pattern passed to 
    pcre_compile() may lead to denial of service.

For Debian 9 stretch, these problems have been fixed in version
3.0.26-3+deb9u2.

We recommend that you upgrade your privoxy packages.

For the detailed security status of privoxy please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/privoxy

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS