- -----------------------------------------------------------------------
Debian LTS Advisory DLA-2625-1              [email protected]
https://www.debian.org/lts/security/                      Utkarsh Gupta
April 14, 2021                              https://wiki.debian.org/LTS
- -----------------------------------------------------------------------

Package        : courier-authlib
Version        : 0.66.4-9+deb9u1
CVE ID         : CVE-2021-28374
Debian Bug     : 984810

The Debian courier-authlib package before 0.71.1-2 for Courier
Authentication Library creates a /run/courier/authdaemon
directory with weak permissions, allowing an attacker to read
user information. This may include a cleartext password in some
configurations. In general, it includes the user's existence,
uid and gids, home and/or Maildir directory, quota, and some
type of password information (such as a hash).

For Debian 9 stretch, this problem has been fixed in version
0.66.4-9+deb9u1.

We recommend that you upgrade your courier-authlib packages.

For the detailed security status of courier-authlib please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/courier-authlib

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS