- -----------------------------------------------------------------------
Debian LTS Advisory DLA-2659-1              [email protected]
https://www.debian.org/lts/security/                      Utkarsh Gupta
May 13, 2021                                https://wiki.debian.org/LTS
- -----------------------------------------------------------------------

Package        : graphviz
Version        : 2.38.0-17+deb9u1
CVE ID         : CVE-2018-10196 CVE-2020-18032
Debian Bug     : 898841 988000

CVE-2018-10196

    NULL pointer dereference vulnerability in the rebuild_vlists
    function in lib/dotgen/conc.c in the dotgen library allows
    remote attackers to cause a denial of service (application
    crash) via a crafted file.

CVE-2020-18032

    A buffer overflow was discovered in Graphviz, which could
    potentially result in the execution of arbitrary code when
    processing a malformed file.

For Debian 9 stretch, these problems have been fixed in version
2.38.0-17+deb9u1.

We recommend that you upgrade your graphviz packages.

For the detailed security status of graphviz please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/graphviz

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS