- -------------------------------------------------------------------------
Debian LTS Advisory DLA-2666-1                [email protected]
https://www.debian.org/lts/security/               Emilio Pozuelo Monfort
May 24, 2021                                  https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : libx11
Version        : 2:1.6.4-3+deb9u4
CVE ID         : CVE-2021-31535
Debian Bug     : 988737

Roman Fiedler found that libX11, the X11 protocol client library, was
vulnerable to protocol command injection due to insufficient validation
of arguments to some functions.

For Debian 9 stretch, this problem has been fixed in version
2:1.6.4-3+deb9u4.

We recommend that you upgrade your libx11 packages.

For the detailed security status of libx11 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libx11

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS