Debian LTS: DLA-2669-1: libxml2 security update

Advisories


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-2669-1                [email protected]
https://www.debian.org/lts/security/                    Thorsten Alteholz
May 30, 2021                                  https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : libxml2
Version        : 2.9.4+dfsg1-2.2+deb9u5
CVE ID         : CVE-2021-3541


An issue has been found in libxml2, the GNOME XML library.
This issue is called "Parameter Laughs"-attack and is related to parameter
entities expansion.
It is similar to the "Billion Laughs"-attacks found earlier in libexpat.
More information can be found at [1]

[1] https://blog.hartwork.org/posts/cve-2021-3541-parameter-laughs-fixed-in-libxml2-2-9-11/


For Debian 9 stretch, this problem has been fixed in version
2.9.4+dfsg1-2.2+deb9u5.

We recommend that you upgrade your libxml2 packages.

For the detailed security status of libxml2 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libxml2

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-2669-1: libxml2 security update

May 30, 2021
An issue has been found in libxml2, the GNOME XML library

Summary

An issue has been found in libxml2, the GNOME XML library.
This issue is called "Parameter Laughs"-attack and is related to parameter
entities expansion.
It is similar to the "Billion Laughs"-attacks found earlier in libexpat.
More information can be found at [1]

[1] https://blog.hartwork.org/posts/cve-2021-3541-parameter-laughs-fixed-in-libxml2-2-9-11/


For Debian 9 stretch, this problem has been fixed in version
2.9.4+dfsg1-2.2+deb9u5.

We recommend that you upgrade your libxml2 packages.

For the detailed security status of libxml2 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libxml2

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


Severity
Package : libxml2
Version : 2.9.4+dfsg1-2.2+deb9u5
CVE ID : CVE-2021-3541

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.