-------------------------------------------------------------------------
Debian LTS Advisory DLA-2695-1                [email protected]
https://www.debian.org/lts/security/                        Ben Hutchings
June 28, 2021                                 https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package        : klibc
Version        : 2.0.4-9+deb9u1
CVE ID         : CVE-2021-31870 CVE-2021-31871 CVE-2021-31872 CVE-2021-31873
Debian Bug     : 989505

Several vulnerabilities have been discovered in klibc.  Depending on
how klibc is used, these could lead to the execution of arbitrary
code, privilege escalation, or denial of service.

Thanks to Microsoft Vulnerability Research for reporting the heap bugs
and going some of the way to identifying the cpio bugs.

CVE-2021-31870

    Multiplication in the calloc() function may result in an integer
    overflow and a subsequent heap buffer overflow.

CVE-2021-31871

    An integer overflow in the cpio command may result in a NULL
    pointer dereference.

CVE-2021-31872

    Multiple possible integer overflows in the cpio command on 32-bit
    systems may result in a buffer overflow or other security impact.

CVE-2021-31873

    Additions in malloc() function may result in integer overflow and
    subsequent heap buffer overflow.

For Debian 9 stretch, these problems have been fixed in version
2.0.4-9+deb9u1.

We recommend that you upgrade your klibc packages.

For the detailed security status of klibc please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/klibc

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

--
Ben Hutchings - Debian developer, member of kernel, installer and LTS teams