- -------------------------------------------------------------------------
Debian LTS Advisory DLA-2707-1                [email protected]
https://www.debian.org/lts/security/                         Anton Gladky
July 12, 2021                                 https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : sogo
Version        : 3.2.6-2+deb9u1
CVE ID         : CVE-2021-33054

One security issue has been discovered in sogo.

SOGo does not validate the signatures of any SAML assertions it receives.
Any actor with network access to the deployment could impersonate users when
SAML is the authentication method.

For Debian 9 stretch, this problem has been fixed in version
3.2.6-2+deb9u1.

We recommend that you upgrade your sogo packages.

ATTENTION! If you are using SAML authentication, use sogo-tool to immediately
delete users sessions and force all users to visit the login page:

    sogo-tool -v expire-sessions 1
    systemctl restart memcached

For the detailed security status of sogo please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/sogo

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS