- -------------------------------------------------------------------------
Debian LTS Advisory DLA-2734-1                [email protected]
https://www.debian.org/lts/security/                          Adrian Bunk
August 09, 2021                               https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : curl
Version        : 7.52.1-5+deb9u15
CVE ID         : CVE-2021-22898 CVE-2021-22924
Debian Bug     : 989228 991492

Several vulnerabilities were fixed in curl,
a client-side URL transfer library.

CVE-2021-22898

    Information disclosure in connection to telnet servers.

CVE-2021-22924

    Bad connection reuse due to flawed path name checks.

For Debian 9 stretch, these problems have been fixed in version
7.52.1-5+deb9u15.

We recommend that you upgrade your curl packages.

For the detailed security status of curl please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/curl

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS