Debian LTS: DLA-2838-1: librecad security update

Advisories


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-2838-1                [email protected]
https://www.debian.org/lts/security/                      Sylvain Beucler
December 03, 2021                             https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : librecad
Version        : 2.1.2-1+deb9u2
CVE ID         : CVE-2021-21898 CVE-2021-21899 CVE-2021-21900

Several vulnerabilities were discovered in LibreCAD, an application
for computer aided design (CAD) in two dimensions. An attacker could
trigger code execution through malicious .dwg and .dxf files.

CVE-2021-21898

    A code execution vulnerability exists in the
    dwgCompressor::decompress18() functionality of LibreCad
    libdxfrw. A specially-crafted .dwg file can lead to an
    out-of-bounds write.

CVE-2021-21899

    A code execution vulnerability exists in the
    dwgCompressor::copyCompBytes21 functionality of LibreCad
    libdxfrw. A specially-crafted .dwg file can lead to a heap buffer
    overflow.

CVE-2021-21900

    A code execution vulnerability exists in the dxfRW::processLType()
    functionality of LibreCad libdxfrw. A specially-crafted .dxf file
    can lead to a use-after-free vulnerability.

For Debian 9 stretch, these problems have been fixed in version
2.1.2-1+deb9u2.

We recommend that you upgrade your librecad packages.

For the detailed security status of librecad please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/librecad

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-2838-1: librecad security update

December 3, 2021
Several vulnerabilities were discovered in LibreCAD, an application for computer aided design (CAD) in two dimensions

Summary

CVE-2021-21898

A code execution vulnerability exists in the
dwgCompressor::decompress18() functionality of LibreCad
libdxfrw. A specially-crafted .dwg file can lead to an
out-of-bounds write.

CVE-2021-21899

A code execution vulnerability exists in the
dwgCompressor::copyCompBytes21 functionality of LibreCad
libdxfrw. A specially-crafted .dwg file can lead to a heap buffer
overflow.

CVE-2021-21900

A code execution vulnerability exists in the dxfRW::processLType()
functionality of LibreCad libdxfrw. A specially-crafted .dxf file
can lead to a use-after-free vulnerability.

For Debian 9 stretch, these problems have been fixed in version
2.1.2-1+deb9u2.

We recommend that you upgrade your librecad packages.

For the detailed security status of librecad please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/librecad

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Severity
Package : librecad
Version : 2.1.2-1+deb9u2
CVE ID : CVE-2021-21898 CVE-2021-21899 CVE-2021-21900

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.