Debian LTS: DLA-2839-1: gerbv security update

Advisories


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-2839-1                [email protected]
https://www.debian.org/lts/security/                         Anton Gladky
December 03, 2021                             https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : gerbv
Version        : 2.6.1-2+deb9u1
CVE ID         : CVE-2021-40391

One security issue has been discovered in gerbv: a viewer for Gerber RS-274X files.

It was discovered that an out-of-bounds write vulnerability exists in the drill
format T-code tool. A specially-crafted drill file can lead to code execution.
An attacker can provide a malicious file to trigger this vulnerability.

For Debian 9 stretch, this problem has been fixed in version
2.6.1-2+deb9u1.

We recommend that you upgrade your gerbv packages.

For the detailed security status of gerbv please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/gerbv

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-2839-1: gerbv security update

December 3, 2021
One security issue has been discovered in gerbv: a viewer for Gerber RS-274X files

Summary

It was discovered that an out-of-bounds write vulnerability exists in the drill
format T-code tool. A specially-crafted drill file can lead to code execution.
An attacker can provide a malicious file to trigger this vulnerability.

For Debian 9 stretch, this problem has been fixed in version
2.6.1-2+deb9u1.

We recommend that you upgrade your gerbv packages.

For the detailed security status of gerbv please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/gerbv

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Severity
Package : gerbv
Version : 2.6.1-2+deb9u1
CVE ID : CVE-2021-40391

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.