- -------------------------------------------------------------------------
Debian LTS Advisory DLA-2966-1                [email protected]
https://www.debian.org/lts/security/                    Thorsten Alteholz
March 30, 2022                                https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : libgc
Version        : 1:7.4.2-8+deb9u1
CVE ID         : CVE-2016-9427


libgc, a conservative garbage collector, is vulnerable to integer 
overflows in multiple places. In some cases, when asked to allocate a huge 
quantity of memory, instead of failing the request, it will return a 
pointer to a small amount of memory possibly tricking the application into 
a buffer overwrite.


For Debian 9 stretch, this problem has been fixed in version
1:7.4.2-8+deb9u1.

We recommend that you upgrade your libgc packages.

For the detailed security status of libgc please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libgc

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS