Debian LTS: DLA-3001-1: libgoogle-gson-java security update | Linux...
-------------------------------------------------------------------------
Debian LTS Advisory DLA-3001-1                [email protected]
https://www.debian.org/lts/security/                       Dominik George
May 13, 2022                                  https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package        : libgoogle-gson-java
Version        : 2.4-1+deb9u1
CVE ID         : CVE-2022-25647
Debian Bug     : 1010670

It was discovered that the package com.google.code.gson:gson
before 2.8.9 is vulnerable to Deserialization of Untrusted Data
via the writeReplace() method in internal classes, which may
lead to DoS attacks.

For Debian 9 stretch, this problem has been fixed in version
2.4-1+deb9u1.

We recommend that you upgrade your libgoogle-gson-java packages.

For the detailed security status of libgoogle-gson-java please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libgoogle-gson-java

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3001-1: libgoogle-gson-java security update

May 13, 2022
It was discovered that the package com.google.code.gson:gson before 2.8.9 is vulnerable to Deserialization of Untrusted Data via the writeReplace() method in internal classes, whic...

Summary

For Debian 9 stretch, this problem has been fixed in version
2.4-1+deb9u1.

We recommend that you upgrade your libgoogle-gson-java packages.

For the detailed security status of libgoogle-gson-java please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libgoogle-gson-java

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Severity
Package : libgoogle-gson-java
Version : 2.4-1+deb9u1
CVE ID : CVE-2022-25647
Debian Bug : 1010670

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.