Debian LTS: DLA-3093-2: rails regression update | LinuxSecurity.com

Advisories


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3093-2                [email protected]
https://www.debian.org/lts/security/                          Abhijith PA
September 15, 2022                            https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : rails
Version        : 2:5.2.2.1+dfsg-1+deb10u5

The security update announced as DLA 3093-1 which included fix 
for CVE-2022-32224 caused a regression due to incompatibility with 
ruby 2.5 version. We have dropped aforementioned fix. Updated rails 
packages are now available.   

For Debian 10 buster, this problem has been fixed in version
2:5.2.2.1+dfsg-1+deb10u5.

We recommend that you upgrade your rails packages.

For the detailed security status of rails please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/rails

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3093-2: rails regression update

September 15, 2022
The security update announced as DLA 3093-1 which included fix for CVE-2022-32224 caused a regression due to incompatibility with ruby 2.5 version

Summary

For Debian 10 buster, this problem has been fixed in version
2:5.2.2.1+dfsg-1+deb10u5.

We recommend that you upgrade your rails packages.

For the detailed security status of rails please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/rails

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Severity
Package : rails
Version : 2:5.2.2.1+dfsg-1+deb10u5

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.