Debian LTS: DLA-3111-1: mod-wsgi security update | LinuxSecurity.com

- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3111-1                [email protected]
https://www.debian.org/lts/security/                    Thorsten Alteholz
September 15, 2022                            https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : mod-wsgi
Version        : 4.6.5-1+deb10u1
CVE ID         : CVE-2022-2255


An issue has been found in mod-wsgi, a Python WSGI adapter module for 
Apache. A request from an untrusted proxy does not remove the X-Client-IP 
header and thus allowing this header to be passed to the target WSGI application.


For Debian 10 buster, this problem has been fixed in version
4.6.5-1+deb10u1.

We recommend that you upgrade your mod-wsgi packages.

For the detailed security status of mod-wsgi please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/mod-wsgi

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3111-1: mod-wsgi security update

September 15, 2022
An issue has been found in mod-wsgi, a Python WSGI adapter module for Apache

Summary

An issue has been found in mod-wsgi, a Python WSGI adapter module for
Apache. A request from an untrusted proxy does not remove the X-Client-IP
header and thus allowing this header to be passed to the target WSGI application.


For Debian 10 buster, this problem has been fixed in version
4.6.5-1+deb10u1.

We recommend that you upgrade your mod-wsgi packages.

For the detailed security status of mod-wsgi please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/mod-wsgi

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


Severity
Package : mod-wsgi
Version : 4.6.5-1+deb10u1
CVE ID : CVE-2022-2255

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.