- - - -------------------------------------------------------------------------
Debian LTS Advisory DLA-3618-1                debian-lts@lists.debian.org
https://www.debian.org/lts/security/                                 Yadd
October 14, 2023                              https://wiki.debian.org/LTS
- - - -------------------------------------------------------------------------

Package        : node-babel
Version        : 6.26.0+dfsg-3+deb10u1
CVE ID         : CVE-2023-45133
Debian Bug     : https://bugs.debian.org/cgi-bin/bugreport.cgi

In @babel/traverse prior to versions 7.23.2 and 8.0.0-alpha.4 and all
versions of `babel-traverse`, using Babel to compile code that was
specifically crafted by an attacker can lead to arbitrary code execution
during compilation, when using plugins that rely on the path.evaluate() or
path.evaluateTruthy() internal Babel methods.

For Debian 10 buster, this problem has been fixed in version
6.26.0+dfsg-3+deb10u1.

We recommend that you upgrade your node-babel packages.

For the detailed security status of node-babel please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/source-package/node-babel

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3618-1: node-babel security update

October 19, 2023
In @babel/traverse prior to versions 7.23.2 and 8.0.0-alpha.4 and all versions of `babel-traverse`, using Babel to compile code that was specifically crafted by an attacker can lea...

Summary

For Debian 10 buster, this problem has been fixed in version
6.26.0+dfsg-3+deb10u1.

We recommend that you upgrade your node-babel packages.

For the detailed security status of node-babel please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/source-package/node-babel

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


Severity
Package : node-babel
Version : 6.26.0+dfsg-3+deb10u1
CVE ID : CVE-2023-45133
Debian Bug : https://bugs.debian.org/cgi-bin/bugreport.cgi

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo