Discover Government News


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3620-1                debian-lts@lists.debian.org
https://www.debian.org/lts/security/                          Adrian Bunk
October 16, 2023                              https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : poppler
Version        : 0.71.0-5+deb10u3
CVE ID         : CVE-2020-23804 CVE-2022-37050 CVE-2022-37051

Several vulnerabilities have been fixed in poppler,
a PDF rendering library.

CVE-2020-23804

    Stack overflow in XRef::readXRefTable()

CVE-2022-37050

    Crash in PDFDoc::savePageAs()

CVE-2022-37051

    Crash in the pdfunite tool

For Debian 10 buster, these problems have been fixed in version
0.71.0-5+deb10u3.

We recommend that you upgrade your poppler packages.

For the detailed security status of poppler please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/source-package/poppler

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3620-1: poppler security update

October 16, 2023
Several vulnerabilities have been fixed in poppler, a PDF rendering library

Summary

CVE-2020-23804

Stack overflow in XRef::readXRefTable()

CVE-2022-37050

Crash in PDFDoc::savePageAs()

CVE-2022-37051

Crash in the pdfunite tool

For Debian 10 buster, these problems have been fixed in version
0.71.0-5+deb10u3.

We recommend that you upgrade your poppler packages.

For the detailed security status of poppler please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/source-package/poppler

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


Severity
Package : poppler
Version : 0.71.0-5+deb10u3
CVE ID : CVE-2020-23804 CVE-2022-37050 CVE-2022-37051

Related News