-------------------------------------------------------------------------
Debian LTS Advisory DLA-3669-1                debian-lts@lists.debian.org
https://www.debian.org/lts/security/                       Guilhem Moulin
November 27, 2023                             https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package        : cryptojs
Version        : 3.1.2+dfsg-2+deb10u1
CVE ID         : CVE-2023-46233
Debian Bug     : 1055525

Thomas Neil James Shadwell reported that cryptojs, a collection of
cryptographic algorithms implemented in JavaScript, had default PBKDF2
settings 1000 times weaker than when specified back in 1993, and 1.3M
times weaker than OWASP's current recommendations.

The default settings are now changed to use SHA256 with 250k iterations.

For Debian 10 buster, this problem has been fixed in version
3.1.2+dfsg-2+deb10u1.

We recommend that you upgrade your cryptojs packages.

For the detailed security status of cryptojs please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/source-package/cryptojs

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3669-1: cryptojs security update

November 27, 2023
Thomas Neil James Shadwell reported that cryptojs, a collection of cryptographic algorithms implemented in JavaScript, had default PBKDF2 settings 1000 times weaker than when speci...

Summary

The default settings are now changed to use SHA256 with 250k iterations.

For Debian 10 buster, this problem has been fixed in version
3.1.2+dfsg-2+deb10u1.

We recommend that you upgrade your cryptojs packages.

For the detailed security status of cryptojs please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/source-package/cryptojs

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


Severity
Package : cryptojs
Version : 3.1.2+dfsg-2+deb10u1
CVE ID : CVE-2023-46233
Debian Bug : 1055525

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo