- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3688-1                debian-lts@lists.debian.org
https://www.debian.org/lts/security/                           Chris Lamb
December 14, 2023                             https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : haproxy
Version        : 1.8.19-1+deb10u5
CVE ID         : CVE-2023-45539

It was discovered that there was a potential information disclosure
vulnerability in HAProxy, a reverse proxy server used to load balance
HTTP requests across multiple servers.

HAProxy formerly accepted the "#" (ie. the "pound" or "hash") symbol
as part of a URI component. This might have allowed remote attackers
to obtain sensitive information upon HAProxy's misinterpretation of a
"path_end" rule, such as by routing "index.html#.png" to a static
server.

For Debian 10 buster, this problem has been fixed in version
1.8.19-1+deb10u5.

We recommend that you upgrade your haproxy packages.

For the detailed security status of haproxy please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/source-package/haproxy

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3688-1: haproxy security update

December 14, 2023
It was discovered that there was a potential information disclosure vulnerability in HAProxy, a reverse proxy server used to load balance HTTP requests across multiple servers

Summary

HAProxy formerly accepted the "#" (ie. the "pound" or "hash") symbol
as part of a URI component. This might have allowed remote attackers
to obtain sensitive information upon HAProxy's misinterpretation of a
"path_end" rule, such as by routing "index.html#.png" to a static
server.

For Debian 10 buster, this problem has been fixed in version
1.8.19-1+deb10u5.

We recommend that you upgrade your haproxy packages.

For the detailed security status of haproxy please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/source-package/haproxy

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



Severity
Package : haproxy
Version : 1.8.19-1+deb10u5
CVE ID : CVE-2023-45539

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo