-------------------------------------------------------------------------
Debian LTS Advisory DLA-3833-1                debian-lts@lists.debian.org
https://www.debian.org/lts/security/                      Markus Koschany
June 17, 2024                                 https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package        : php7.3
Version        : 7.3.31-1~deb10u7
CVE ID         : CVE-2024-5458
Debian Bug     : 1072885

PHP, a widely-used open source general purpose scripting language, is affected
by a security problem when parsing certain types of URLs.

Due to a code logic error filtering functions such as filter_var when
validating URLs (FILTER_VALIDATE_URL) will result in invalid user information
(username + password part of URLs) being treated as valid user information.
This may lead to the downstream code accepting invalid URLs as valid and
parsing them incorrectly. The problem is related to CVE-2020-7071 but affects
IPv6 host parts.

For Debian 10 buster, this problem has been fixed in version
7.3.31-1~deb10u7.

We recommend that you upgrade your php7.3 packages.

For the detailed security status of php7.3 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/php7.3

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3833-1: php7.3 Security Advisory Updates

June 18, 2024
PHP, a widely-used open source general purpose scripting language, is affected by a security problem when parsing certain types of URLs

Summary

Due to a code logic error filtering functions such as filter_var when
validating URLs (FILTER_VALIDATE_URL) will result in invalid user information
(username + password part of URLs) being treated as valid user information.
This may lead to the downstream code accepting invalid URLs as valid and
parsing them incorrectly. The problem is related to CVE-2020-7071 but affects
IPv6 host parts.

For Debian 10 buster, this problem has been fixed in version
7.3.31-1~deb10u7.

We recommend that you upgrade your php7.3 packages.

For the detailed security status of php7.3 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/php7.3

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


Severity
Package : php7.3
Version : 7.3.31-1~deb10u7
CVE ID : CVE-2024-5458
Debian Bug : 1072885

Related News