- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3837-1                debian-lts@lists.debian.org
https://www.debian.org/lts/security/                           Chris Lamb
June 19, 2024                                 https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : libndp
Version        : 1.6-1+deb10u1
CVE ID         : CVE-2024-5564
Debian Bug     : 1072366

It was discovered that there was a buffer overflow vulnerability in
libndp, a library for implementing IPv6's "Neighbor Discovery
Protocol" (NDP) and is used by Network Manager and other networking
tools.

A local, malicious user could have caused a buffer overflow in
Network Manager by sending a malformed IPv6 router advertisement
packet. This issue existed because libndp was not correctly
validating route length information.

For Debian 10 buster, this problem has been fixed in version
1.6-1+deb10u1.

We recommend that you upgrade your libndp packages.

For the detailed security status of libndp please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libndp

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3837-1: libndp Security Advisory Updates

June 19, 2024
It was discovered that there was a buffer overflow vulnerability in libndp, a library for implementing IPv6's "Neighbor Discovery Protocol" (NDP) and is used by Network Manager and...

Summary

A local, malicious user could have caused a buffer overflow in
Network Manager by sending a malformed IPv6 router advertisement
packet. This issue existed because libndp was not correctly
validating route length information.

For Debian 10 buster, this problem has been fixed in version
1.6-1+deb10u1.

We recommend that you upgrade your libndp packages.

For the detailed security status of libndp please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libndp

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



Severity
Package : libndp
Version : 1.6-1+deb10u1
CVE ID : CVE-2024-5564
Debian Bug : 1072366

Related News