--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2009-7961
2009-07-23 18:32:19
--------------------------------------------------------------------------------

Name        : ruby-gnome2
Product     : Fedora 10
Version     : 0.19.0
Release     : 3.fc10.1
URL         : Summary     : Ruby binding of libgnome/libgnomeui-2.x
Description :
This is a set of bindings for the GNOME-2.x libraries for use from Ruby.

--------------------------------------------------------------------------------
Update Information:

Update to new upstream Firefox version 3.0.12, fixing multiple security issues
detailed in the upstream advisories:    http://www.mozilla.org/security/known-vulnerabilities/firefox30.html#firefox3.0.12    Update also includes all
packages depending on gecko-libs rebuilt against new version of Firefox /
XULRunner.
--------------------------------------------------------------------------------
ChangeLog:

* Tue Jul 21 2009 Jan Horak  - 0.19.0-3.1
- Rebuild against newer gecko
* Thu Jul 16 2009 Mamoru Tasaka  - 0.19.0-3
- Make ruby-gtkglext require ruby(opengl)
* Wed Jul  1 2009 Mamoru Tasaka  - 0.19.0-2
- Install more needed header files in ruby-gtk2-devel (bug 509035)
- Keep timestamps on installed header files
* Thu Jun 18 2009 Mamoru Tasaka  - 0.19.0-1
- Update to 0.19.0
* Thu Jun 11 2009 Christopher Aillon  - 0.18.1-5.3
- Rebuild against newer gecko
* Mon Apr 27 2009 Christopher Aillon  - 0.18.1-5.2
- Rebuild against newer gecko
* Tue Apr 21 2009 Christopher Aillon  - 0.18.1-5.1
- Rebuild against newer gecko
* Fri Mar 27 2009 Christopher Aillon  - 0.18.1-5
- Rebuild against newer gecko
* Fri Mar  6 2009 Jan Horak  - 0.18.1-4
- Rebuild against newer gecko
* Wed Feb  4 2009 Christopher Aillon  - 0.18.1-3
- Rebuild against newer gecko
* Wed Dec 17 2008 Christopher Aillon  - 0.18.1-2
- Rebuild against newer gecko
* Thu Nov 13 2008 Allisson Azevedo  0.18.1-1
- Update to 0.18.1
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #512131 - CVE-2009-2463 Mozilla Base64 decoding crash
        https://bugzilla.redhat.com/show_bug.cgi?id=512131
  [ 2 ] Bug #512133 - CVE-2009-2464 Mozilla crash with multiple RDFs in XUL tree
        https://bugzilla.redhat.com/show_bug.cgi?id=512133
  [ 3 ] Bug #512135 - CVE-2009-2465 Mozilla double frame construction crashes
        https://bugzilla.redhat.com/show_bug.cgi?id=512135
  [ 4 ] Bug #512128 - CVE-2009-2462 Mozilla Browser engine crashes
        https://bugzilla.redhat.com/show_bug.cgi?id=512128
  [ 5 ] Bug #512136 - CVE-2009-2466 Mozilla JavaScript engine crashes
        https://bugzilla.redhat.com/show_bug.cgi?id=512136
  [ 6 ] Bug #512137 - CVE-2009-2467 Mozilla remote code execution during Flash player unloading
        https://bugzilla.redhat.com/show_bug.cgi?id=512137
  [ 7 ] Bug #512142 - CVE-2009-2469 Mozilla remote code execution using watch and __defineSetter__ on SVG element
        https://bugzilla.redhat.com/show_bug.cgi?id=512142
  [ 8 ] Bug #512146 - CVE-2009-2471 Mozilla setTimeout loses XPCNativeWrappers        https://bugzilla.redhat.com/show_bug.cgi?id=512146
  [ 9 ] Bug #512147 - CVE-2009-2472 Mozilla multiple cross origin wrapper bypasses
        https://bugzilla.redhat.com/show_bug.cgi?id=512147
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update ruby-gnome2' at the command line.
For more information, refer to "Managing Software with yum",
available at .

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
http://fedoraproject.org/keys
--------------------------------------------------------------------------------

_______________________________________________
Fedora-package-announce mailing list
Fedora-package-announce@redhat.com
http://www.redhat.com/mailman/listinfo/fedora-package-announce

Fedora 10 Update: ruby-gnome2-0.19.0-3.fc10.1

July 23, 2009
Update to new upstream Firefox version 3.0.12, fixing multiple security issues detailed in the upstream advisories: http://www.mozilla.org/security/known-vulnerabilities/firefo...

Summary

This is a set of bindings for the GNOME-2.x libraries for use from Ruby.

Update Information:

Update to new upstream Firefox version 3.0.12, fixing multiple security issues detailed in the upstream advisories: http://www.mozilla.org/security/known-vulnerabilities/firefox30.html#firefox3.0.12 Update also includes all packages depending on gecko-libs rebuilt against new version of Firefox / XULRunner.

Change Log

* Tue Jul 21 2009 Jan Horak - 0.19.0-3.1 - Rebuild against newer gecko * Thu Jul 16 2009 Mamoru Tasaka - 0.19.0-3 - Make ruby-gtkglext require ruby(opengl) * Wed Jul 1 2009 Mamoru Tasaka - 0.19.0-2 - Install more needed header files in ruby-gtk2-devel (bug 509035) - Keep timestamps on installed header files * Thu Jun 18 2009 Mamoru Tasaka - 0.19.0-1 - Update to 0.19.0 * Thu Jun 11 2009 Christopher Aillon - 0.18.1-5.3 - Rebuild against newer gecko * Mon Apr 27 2009 Christopher Aillon - 0.18.1-5.2 - Rebuild against newer gecko * Tue Apr 21 2009 Christopher Aillon - 0.18.1-5.1 - Rebuild against newer gecko * Fri Mar 27 2009 Christopher Aillon - 0.18.1-5 - Rebuild against newer gecko * Fri Mar 6 2009 Jan Horak - 0.18.1-4 - Rebuild against newer gecko * Wed Feb 4 2009 Christopher Aillon - 0.18.1-3 - Rebuild against newer gecko * Wed Dec 17 2008 Christopher Aillon - 0.18.1-2 - Rebuild against newer gecko * Thu Nov 13 2008 Allisson Azevedo 0.18.1-1 - Update to 0.18.1

References

[ 1 ] Bug #512131 - CVE-2009-2463 Mozilla Base64 decoding crash https://bugzilla.redhat.com/show_bug.cgi?id=512131 [ 2 ] Bug #512133 - CVE-2009-2464 Mozilla crash with multiple RDFs in XUL tree https://bugzilla.redhat.com/show_bug.cgi?id=512133 [ 3 ] Bug #512135 - CVE-2009-2465 Mozilla double frame construction crashes https://bugzilla.redhat.com/show_bug.cgi?id=512135 [ 4 ] Bug #512128 - CVE-2009-2462 Mozilla Browser engine crashes https://bugzilla.redhat.com/show_bug.cgi?id=512128 [ 5 ] Bug #512136 - CVE-2009-2466 Mozilla JavaScript engine crashes https://bugzilla.redhat.com/show_bug.cgi?id=512136 [ 6 ] Bug #512137 - CVE-2009-2467 Mozilla remote code execution during Flash player unloading https://bugzilla.redhat.com/show_bug.cgi?id=512137 [ 7 ] Bug #512142 - CVE-2009-2469 Mozilla remote code execution using watch and __defineSetter__ on SVG element https://bugzilla.redhat.com/show_bug.cgi?id=512142 [ 8 ] Bug #512146 - CVE-2009-2471 Mozilla setTimeout loses XPCNativeWrappers https://bugzilla.redhat.com/show_bug.cgi?id=512146 [ 9 ] Bug #512147 - CVE-2009-2472 Mozilla multiple cross origin wrapper bypasses https://bugzilla.redhat.com/show_bug.cgi?id=512147

Update Instructions

This update can be installed with the "yum" update program. Use su -c 'yum update ruby-gnome2' at the command line. For more information, refer to "Managing Software with yum", available at .

Severity
Name : ruby-gnome2
Product : Fedora 10
Version : 0.19.0
Release : 3.fc10.1
URL : Summary : Ruby binding of libgnome/libgnomeui-2.x