--------------------------------------------------------------------------------Fedora Update Notification
FEDORA-2018-1cbdc8cbb8
2018-03-06 17:17:51.858805
--------------------------------------------------------------------------------Name        : glibc
Product     : Fedora 27
Version     : 2.26
Release     : 26.fc27
URL         : http://www.gnu.org/software/glibc/
Summary     : The GNU libc libraries
Description :
The glibc package contains standard libraries which are used by
multiple programs on the system. In order to save disk space and
memory, as well as to make upgrading easier, common system code is
kept in one place and shared between programs. This particular package
contains the most important sets of shared libraries: the standard C
library and the standard math library. Without these two libraries, a
Linux system will not function.

--------------------------------------------------------------------------------Update Information:

This update fixes two minor security vulnerabilities in `malloc` (CVE-2018-6485,
CVE-2018-6551, RHBZ#1542102, RHBZ#1542119), and provides a C++ version of
`iseqsig`.
--------------------------------------------------------------------------------References:

  [ 1 ] Bug #1542102 - CVE-2018-6485 glibc: Integer overflow in posix_memalign in memalign functions
        https://bugzilla.redhat.com/show_bug.cgi?id=1542102
--------------------------------------------------------------------------------This update can be installed with the "dnf" update program. Use
su -c 'dnf upgrade glibc' at the command line.
For more information, refer to the dnf documentation available at
https://dnf.readthedocs.io/en/latest/command_ref.html

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
--------------------------------------------------------------------------------
_______________________________________________
package-announce mailing list -- package-announce@lists.fedoraproject.org
To unsubscribe send an email to package-announce-leave@lists.fedoraproject.org

Fedora 27: glibc Security Update 2018-1cbdc8cbb8

March 6, 2018
This update fixes two minor security vulnerabilities in `malloc` (CVE-2018-6485, CVE-2018-6551, RHBZ#1542102, RHBZ#1542119), and provides a C++ version of `iseqsig`.

Summary

The glibc package contains standard libraries which are used by

multiple programs on the system. In order to save disk space and

memory, as well as to make upgrading easier, common system code is

kept in one place and shared between programs. This particular package

contains the most important sets of shared libraries: the standard C

library and the standard math library. Without these two libraries, a

Linux system will not function.

This update fixes two minor security vulnerabilities in `malloc` (CVE-2018-6485,

CVE-2018-6551, RHBZ#1542102, RHBZ#1542119), and provides a C++ version of

`iseqsig`.

[ 1 ] Bug #1542102 - CVE-2018-6485 glibc: Integer overflow in posix_memalign in memalign functions

https://bugzilla.redhat.com/show_bug.cgi?id=1542102

su -c 'dnf upgrade glibc' at the command line.

For more information, refer to the dnf documentation available at

https://dnf.readthedocs.io/en/latest/command_ref.html

All packages are signed with the Fedora Project GPG key. More details on the

GPG keys used by the Fedora Project can be found at

package-announce mailing list -- package-announce@lists.fedoraproject.org

To unsubscribe send an email to package-announce-leave@lists.fedoraproject.org

FEDORA-2018-1cbdc8cbb8 2018-03-06 17:17:51.858805 Product : Fedora 27 Version : 2.26 Release : 26.fc27 URL : http://www.gnu.org/software/glibc/ Summary : The GNU libc libraries Description : The glibc package contains standard libraries which are used by multiple programs on the system. In order to save disk space and memory, as well as to make upgrading easier, common system code is kept in one place and shared between programs. This particular package contains the most important sets of shared libraries: the standard C library and the standard math library. Without these two libraries, a Linux system will not function. This update fixes two minor security vulnerabilities in `malloc` (CVE-2018-6485, CVE-2018-6551, RHBZ#1542102, RHBZ#1542119), and provides a C++ version of `iseqsig`. [ 1 ] Bug #1542102 - CVE-2018-6485 glibc: Integer overflow in posix_memalign in memalign functions https://bugzilla.redhat.com/show_bug.cgi?id=1542102 su -c 'dnf upgrade glibc' at the command line. For more information, refer to the dnf documentation available at https://dnf.readthedocs.io/en/latest/command_ref.html All packages are signed with the Fedora Project GPG key. More details on the GPG keys used by the Fedora Project can be found at package-announce mailing list -- package-announce@lists.fedoraproject.org To unsubscribe send an email to package-announce-leave@lists.fedoraproject.org

Change Log

References

Update Instructions

Severity
Product : Fedora 27
Version : 2.26
Release : 26.fc27
URL : http://www.gnu.org/software/glibc/
Summary : The GNU libc libraries

Related News