--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2023-9d36d373f1
2023-10-23 01:24:04.606330
--------------------------------------------------------------------------------

Name        : python-asgiref
Product     : Fedora 37
Version     : 3.5.2
Release     : 1.fc37
URL         : https://github.com/django/asgiref
Summary     : ASGI specs, helper code, and adapters
Description :
ASGI is a standard for Python asynchronous web apps and servers to communicate
with each other, and positioned as an asynchronous successor to WSGI.  This
package includes ASGI base libraries, such as:

* Sync-to-async and async-to-sync function wrappers, asgiref.sync
* Server base classes, asgiref.server
* A WSGI-to-ASGI adapter, in asgiref.wsgi

--------------------------------------------------------------------------------
Update Information:

Security fix for CVE-2023-43665, CVE-2023-41164, and CVE-2023-36053
--------------------------------------------------------------------------------
ChangeLog:

* Mon Feb 13 2023 Joel Capitao  - 3.5.2-1
- Update to 3.5.2
* Fri Jan 20 2023 Fedora Release Engineering  - 3.4.1-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #2219383 - CVE-2023-36053 python-django: Potential regular expression denial of service vulnerability in EmailValidator/URLValidator [fedora-all]
        https://bugzilla.redhat.com/show_bug.cgi?id=2219383
  [ 2 ] Bug #2237870 - CVE-2023-41164 python-django: Potential denial of service vulnerability in  ``django.utils.encoding.uri_to_iri()`` [fedora-all]
        https://bugzilla.redhat.com/show_bug.cgi?id=2237870
  [ 3 ] Bug #2242182 - CVE-2023-43665 python-django: Denial-of-service possibility in django.utils.text.Truncator [fedora-all]
        https://bugzilla.redhat.com/show_bug.cgi?id=2242182
--------------------------------------------------------------------------------

This update can be installed with the "dnf" update program. Use
su -c 'dnf upgrade --advisory FEDORA-2023-9d36d373f1' at the command
line. For more information, refer to the dnf documentation available at
https://dnf.readthedocs.io/en/latest/command_ref.html

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/security/
--------------------------------------------------------------------------------
_______________________________________________
package-announce mailing list -- package-announce@lists.fedoraproject.org
To unsubscribe send an email to package-announce-leave@lists.fedoraproject.org
Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org
Do not reply to spam, report it: https://pagure.io/login/

Fedora 37: python-asgiref 2023-9d36d373f1

October 23, 2023
Security fix for CVE-2023-43665, CVE-2023-41164, and CVE-2023-36053

Summary

ASGI is a standard for Python asynchronous web apps and servers to communicate

with each other, and positioned as an asynchronous successor to WSGI. This

package includes ASGI base libraries, such as:

* Sync-to-async and async-to-sync function wrappers, asgiref.sync

* Server base classes, asgiref.server

* A WSGI-to-ASGI adapter, in asgiref.wsgi

Update Information:

Security fix for CVE-2023-43665, CVE-2023-41164, and CVE-2023-36053

Change Log

* Mon Feb 13 2023 Joel Capitao - 3.5.2-1 - Update to 3.5.2 * Fri Jan 20 2023 Fedora Release Engineering - 3.4.1-8 - Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild

References

[ 1 ] Bug #2219383 - CVE-2023-36053 python-django: Potential regular expression denial of service vulnerability in EmailValidator/URLValidator [fedora-all] https://bugzilla.redhat.com/show_bug.cgi?id=2219383 [ 2 ] Bug #2237870 - CVE-2023-41164 python-django: Potential denial of service vulnerability in ``django.utils.encoding.uri_to_iri()`` [fedora-all] https://bugzilla.redhat.com/show_bug.cgi?id=2237870 [ 3 ] Bug #2242182 - CVE-2023-43665 python-django: Denial-of-service possibility in django.utils.text.Truncator [fedora-all] https://bugzilla.redhat.com/show_bug.cgi?id=2242182

Update Instructions

This update can be installed with the "dnf" update program. Use su -c 'dnf upgrade --advisory FEDORA-2023-9d36d373f1' at the command line. For more information, refer to the dnf documentation available at https://dnf.readthedocs.io/en/latest/command_ref.html

Severity
Name : python-asgiref
Product : Fedora 37
Version : 3.5.2
Release : 1.fc37
URL : https://github.com/django/asgiref
Summary : ASGI specs, helper code, and adapters

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo