Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200610-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Python: Buffer Overflow
      Date: October 17, 2006
      Bugs: #149065
        ID: 200610-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
A buffer overflow in Python's "repr()" function can be exploited to
cause a Denial of Service and potentially allows the execution of
arbitrary code.

Background
=========
Python is an interpreted, interactive, object-oriented, cross-platform
programming language.

Affected packages
================
    -------------------------------------------------------------------
     Package          /  Vulnerable  /                      Unaffected
    -------------------------------------------------------------------
  1  dev-lang/python     < 2.4.3-r4                        >= 2.4.3-r4
                                                          *>= 2.3.5-r3

Description
==========
Benjamin C. Wiley Sittler discovered a buffer overflow in Python's
"repr()" function when handling UTF-32/UCS-4 encoded strings.

Impact
=====
If a Python application processes attacker-supplied data with the
"repr()" function, this could potentially lead to the execution of
arbitrary code with the privileges of the affected application or a
Denial of Service.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All Python users should update to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-lang/2.4.3-r4"

References
=========
  [ 1 ] CVE-2006-4980
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-4980

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/200610-07

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org/.

License
======
Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/

Gentoo: GLSA-200610-07: Python: Buffer Overflow

A buffer overflow in Python's "repr()" function can be exploited to cause a Denial of Service and potentially allows the execution of arbitrary code

Summary

Gentoo Linux Security Advisory GLSA 200610-07 https://security.gentoo.org/ Severity: Normal Title: Python: Buffer Overflow Date: October 17, 2006 Bugs: #149065 ID: 200610-07

Synopsis ======= A buffer overflow in Python's "repr()" function can be exploited to cause a Denial of Service and potentially allows the execution of arbitrary code.
Background ========= Python is an interpreted, interactive, object-oriented, cross-platform programming language.
Affected packages ================ ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-lang/python < 2.4.3-r4 >= 2.4.3-r4 *>= 2.3.5-r3
========== Benjamin C. Wiley Sittler discovered a buffer overflow in Python's "repr()" function when handling UTF-32/UCS-4 encoded strings.
Impact ===== If a Python application processes attacker-supplied data with the "repr()" function, this could potentially lead to the execution of arbitrary code with the privileges of the affected application or a Denial of Service.
Workaround ========= There is no known workaround at this time.
Resolution ========= All Python users should update to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/2.4.3-r4"
References ========= [ 1 ] CVE-2006-4980 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-4980
Availability =========== This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/200610-07
Concerns? ======== Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org/.
License ====== Copyright 2006 Gentoo Foundation, Inc; referenced text belongs to its owner(s).
The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.
https://creativecommons.org/licenses/by-sa/2.5/

Resolution

References

Availability

Concerns

Severity

Synopsis

Background

Affected Packages

Impact

Workaround

Related News