Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200705-24
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: libpng: Denial of Service
      Date: May 31, 2007
      Bugs: #178004
        ID: 200705-24

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
A vulnerability in libpng may allow a remote attacker to crash
applications that handle untrusted images.

Background
=========
libpng is a free ANSI C library used to process and manipulate PNG
images.

Affected packages
================
    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  media-libs/libpng      < 1.2.17                         >= 1.2.17

Description
==========
Mats Palmgren fixed an error in file pngrutil.c in which the trans[]
array might be not allocated because of images with a bad tRNS chunk
CRC value.

Impact
=====
A remote attacker could craft an image that when processed or viewed by
an application using libpng causes the application to terminate
abnormally.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
Please note that due to separate bugs in libpng 1.2.17, Gentoo does not
provide libpng-1.2.17 but libpng-1.2.18. All libpng users should
upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.2.18"

References
=========
  [ 1 ] CVE-2007-2445
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2445

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/200705-24

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org/.

License
======
Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/

Gentoo: GLSA-200705-24: libpng: Denial of Service

A vulnerability in libpng may allow a remote attacker to crash applications that handle untrusted images.

Summary

Gentoo Linux Security Advisory GLSA 200705-24 https://security.gentoo.org/ Severity: Normal Title: libpng: Denial of Service Date: May 31, 2007 Bugs: #178004 ID: 200705-24

Synopsis ======= A vulnerability in libpng may allow a remote attacker to crash applications that handle untrusted images.
Background ========= libpng is a free ANSI C library used to process and manipulate PNG images.
Affected packages ================ ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 media-libs/libpng < 1.2.17 >= 1.2.17
========== Mats Palmgren fixed an error in file pngrutil.c in which the trans[] array might be not allocated because of images with a bad tRNS chunk CRC value.
Impact ===== A remote attacker could craft an image that when processed or viewed by an application using libpng causes the application to terminate abnormally.
Workaround ========= There is no known workaround at this time.
Resolution ========= Please note that due to separate bugs in libpng 1.2.17, Gentoo does not provide libpng-1.2.17 but libpng-1.2.18. All libpng users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.2.18"
References ========= [ 1 ] CVE-2007-2445 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2445
Availability =========== This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/200705-24
Concerns? ======== Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org/.
License ====== Copyright 2007 Gentoo Foundation, Inc; referenced text belongs to its owner(s).
The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.
https://creativecommons.org/licenses/by-sa/2.5/

Resolution

References

Availability

Concerns

Severity

Synopsis

Background

Affected Packages

Impact

Workaround

Related News