Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200708-14
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: NVIDIA drivers: Denial of Service
      Date: August 19, 2007
      Bugs: #183567
        ID: 200708-14

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
A vulnerability has been discovered in the NVIDIA graphic drivers,
allowing for a Denial of Service.

Background
=========
The NVIDIA drivers provide support for NVIDIA graphic boards.

Affected packages
================
    -------------------------------------------------------------------
     Package                     /   Vulnerable   /         Unaffected
    -------------------------------------------------------------------
  1  x11-drivers/nvidia-drivers      < 100.14.09          >= 100.14.09
                                                          *>= 1.0.9639
                                                          *>= 1.0.7185

Description
==========
Gregory Shikhman discovered that the default Gentoo setup of NVIDIA
drivers creates the /dev/nvidia* with insecure file permissions.

Impact
=====
A local attacker could send arbitrary values into the devices, possibly
resulting in hardware damage on the graphic board or a Denial of
Service.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All NVIDIA drivers users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose "x11-drivers/nvidia-drivers"

References
=========
  [ 1 ] CVE-2007-3532
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-3532

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/200708-14

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org/.

License
======
Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/

Gentoo: GLSA-200708-14: NVIDIA drivers: Denial of Service

A vulnerability has been discovered in the NVIDIA graphic drivers, allowing for a Denial of Service.

Summary

Gentoo Linux Security Advisory GLSA 200708-14 https://security.gentoo.org/ Severity: Normal Title: NVIDIA drivers: Denial of Service Date: August 19, 2007 Bugs: #183567 ID: 200708-14

Synopsis ======= A vulnerability has been discovered in the NVIDIA graphic drivers, allowing for a Denial of Service.
Background ========= The NVIDIA drivers provide support for NVIDIA graphic boards.
Affected packages ================ ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 x11-drivers/nvidia-drivers < 100.14.09 >= 100.14.09 *>= 1.0.9639 *>= 1.0.7185
========== Gregory Shikhman discovered that the default Gentoo setup of NVIDIA drivers creates the /dev/nvidia* with insecure file permissions.
Impact ===== A local attacker could send arbitrary values into the devices, possibly resulting in hardware damage on the graphic board or a Denial of Service.
Workaround ========= There is no known workaround at this time.
Resolution ========= All NVIDIA drivers users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose "x11-drivers/nvidia-drivers"
References ========= [ 1 ] CVE-2007-3532 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-3532
Availability =========== This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/200708-14
Concerns? ======== Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org/.
License ====== Copyright 2007 Gentoo Foundation, Inc; referenced text belongs to its owner(s).
The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.
https://creativecommons.org/licenses/by-sa/2.5/

Resolution

References

Availability

Concerns

Severity

Synopsis

Background

Affected Packages

Impact

Workaround

Related News