Gentoo: GLSA-201408-15: PostgreSQL: Multiple vulnerabilities

    Date 29 Aug 2014
    102
    Posted By LinuxSecurity Advisories
    Multiple vulnerabilities have been found in PostgreSQL, the worst of which may allow remote Denial of Service.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 201408-15
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                https://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: Normal
        Title: PostgreSQL: Multiple vulnerabilities
         Date: August 29, 2014
         Bugs: #456080, #463884, #501946
           ID: 201408-15
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple vulnerabilities have been found in PostgreSQL, the worst of
    which may allow remote Denial of Service.
    
    Background
    ==========
    
    PostgreSQL is an open source object-relational database management
    system.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  dev-db/postgresql-server
                                      < 9.3.3                  *>= 8.4.20
                                                               *>= 9.1.12
                                                                *>= 9.2.7
                                                               *>= 9.0.16
                                                                 >= 9.3.3
    
    Description
    ===========
    
    Multiple vulnerabilities have been discovered in PostgreSQL. Please
    review the CVE identifiers referenced below for details.
    
    Impact
    ======
    
    A remote authenticated attacker may be able to create a Denial of
    Service condition, bypass security restrictions, or have other
    unspecified impact.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All PostgreSQL 9.3 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-9.3.3"
    
    All PostgreSQL 9.2 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-9.2.7"
    
    All PostgreSQL 9.1 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot -v ">=dev-db/postgresql-server-9.1.12"
    
    All PostgreSQL 9.0 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot -v ">=dev-db/postgresql-server-9.0.16"
    
    All PostgreSQL 8.4 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot -v ">=dev-db/postgresql-server-8.4.20"
    
    References
    ==========
    
    [  1 ] CVE-2013-0255
           https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-0255
    [  2 ] CVE-2013-1899
           https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-1899
    [  3 ] CVE-2013-1900
           https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-1900
    [  4 ] CVE-2013-1901
           https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-1901
    [  5 ] CVE-2014-0060
           https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0060
    [  6 ] CVE-2014-0061
           https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0061
    [  7 ] CVE-2014-0062
           https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0062
    [  8 ] CVE-2014-0063
           https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0063
    [  9 ] CVE-2014-0064
           https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0064
    [ 10 ] CVE-2014-0065
           https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0065
    [ 11 ] CVE-2014-0066
           https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0066
    [ 12 ] CVE-2014-2669
           https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2669
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     https://security.gentoo.org/glsa/glsa-201408-15.xml
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2014 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    https://creativecommons.org/licenses/by-sa/2.5
    
    

    LinuxSecurity Poll

    Are you considering making the switch to Purism's new Librem 14 Linux laptop to improve your security and privacy online?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/31-are-you-considering-making-the-switch-to-purism-s-new-librem-14-linux-laptop-to-improve-your-security-and-privacy-online?task=poll.vote&format=json
    31
    radio
    [{"id":"109","title":"Yes - the hardware kill switches and default ad blocking\/tracking protection sold me on it.","votes":"2","type":"x","order":"1","pct":40,"resources":[]},{"id":"110","title":"Not sure yet - I need to do more research.","votes":"2","type":"x","order":"2","pct":40,"resources":[]},{"id":"111","title":"No - I'm satisfied with my current laptop and have no security\/privacy concerns.","votes":"1","type":"x","order":"3","pct":20,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.