Gentoo: GLSA-201411-08: Aircrack-ng: User-assisted execution of arbitrary code

    Date23 Nov 2014
    CategoryGentoo
    44
    Posted ByLinuxSecurity Advisories
    Multiple vulnerabilities have been found in Aircrack-ng, possibly resulting in local privilege escalation, remote code execution, or Denial of Service. [More...]
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 201411-08
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                http://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: Normal
        Title: Aircrack-ng: User-assisted execution of arbitrary code
         Date: November 23, 2014
         Bugs: #528132
           ID: 201411-08
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple vulnerabilities have been found in Aircrack-ng, possibly
    resulting in local privilege escalation, remote code execution, or
    Denial of Service.
    
    Background
    ==========
    
    Aircrack-ng is an 802.11 WEP and WPA-PSK keys cracking program that can
    recover keys once enough data packets have been captured.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  net-wireless/aircrack-ng
                                     < 1.2_rc1 >= 1.2_rc1
    
    Description
    ===========
    
    Multiple vulnerabilities have been discovered in Aircrack-ng. Please
    review the CVE identifiers referenced below for details.
    
    Impact
    ======
    
    A local attacker can use this flaw to execute arbitrary code or gain
    escalated privileges. A remote attacker execute arbitrary code with the
    privileges of the process or a Denial of Service condition.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All Aircrack-ng users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot -v ">=net-wireless/aircrack-ng-1.2_rc1"
    
    References
    ==========
    
    [ 1 ] CVE-2014-8321
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-8321
    [ 2 ] CVE-2014-8322
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-8322
    [ 3 ] CVE-2014-8323
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-8323
    [ 4 ] CVE-2014-8324
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-8324
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     http://security.gentoo.org/glsa/glsa-201411-08.xml
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2014 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    http://creativecommons.org/licenses/by-sa/2.5
    
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"5","type":"x","order":"1","pct":55.56,"resources":[]},{"id":"88","title":"Should be more technical","votes":"3","type":"x","order":"2","pct":33.33,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"1","type":"x","order":"3","pct":11.11,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    Advisories

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.