Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201612-19
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Mercurial: Multiple vulnerabilities
     Date: December 07, 2016
     Bugs: #533008, #544332, #578546, #582238
       ID: 201612-19

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
Multiple vulnerabilities have been found in Mercurial, the worst of
which could lead to the remote execution of arbitrary code.

Background
=========
Mercurial is a distributed source control management system.

Affected packages
================
    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-vcs/mercurial            < 3.8.4                    >= 3.8.4 

Description
==========
Multiple vulnerabilities have been discovered in Mercurial. Please
review the CVE identifier and bug reports referenced for details.

Impact
=====
A remote attacker could possibly execute arbitrary code with the
privileges of the process.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All mercurial users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-vcs/mercurial-3.8.4"

References
=========
[ 1 ] CVE-2014-9390
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-9390
[ 2 ] CVE-2014-9462
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-9462
[ 3 ] CVE-2016-3068
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-3068
[ 4 ] CVE-2016-3069
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-3069
[ 5 ] CVE-2016-3105
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-3105
[ 6 ] CVE-2016-3630
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-3630

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/201612-19

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
======
Copyright 2016 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/

Gentoo: GLSA-201612-19: Mercurial: Multiple vulnerabilities

Multiple vulnerabilities have been found in Mercurial, the worst of which could lead to the remote execution of arbitrary code.

Summary

Multiple vulnerabilities have been discovered in Mercurial. Please review the CVE identifier and bug reports referenced for details.

Resolution

All mercurial users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=dev-vcs/mercurial-3.8.4"

References

[ 1 ] CVE-2014-9390 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-9390 [ 2 ] CVE-2014-9462 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-9462 [ 3 ] CVE-2016-3068 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-3068 [ 4 ] CVE-2016-3069 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-3069 [ 5 ] CVE-2016-3105 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-3105 [ 6 ] CVE-2016-3630 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-3630

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website: https://security.gentoo.org/glsa/201612-19

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Normal
Title: Mercurial: Multiple vulnerabilities
Date: December 07, 2016
Bugs: #533008, #544332, #578546, #582238
ID: 201612-19

Synopsis

Multiple vulnerabilities have been found in Mercurial, the worst of which could lead to the remote execution of arbitrary code.

Background

Mercurial is a distributed source control management system.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-vcs/mercurial < 3.8.4 >= 3.8.4

Impact

===== A remote attacker could possibly execute arbitrary code with the privileges of the process.

Workaround

There is no known workaround at this time.

Related News