Gentoo: GLSA-201908-05: LibVNCServer: Multiple vulnerabilities

    Date09 Aug 2019
    CategoryGentoo
    519
    Posted ByLinuxSecurity Advisories
    Multiple vulnerabilities have been found in LibVNCServer, the worst of which could result in the arbitrary execution of code.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 201908-05
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                               https://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: Normal
        Title: LibVNCServer: Multiple vulnerabilities
         Date: August 09, 2019
         Bugs: #659560, #673508
           ID: 201908-05
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple vulnerabilities have been found in LibVNCServer, the worst of
    which could result in the arbitrary execution of code.
    
    Background
    ==========
    
    LibVNCServer/LibVNCClient are cross-platform C libraries that allow you
    to easily implement VNC server or client functionality in your program.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  net-libs/libvncserver        < 0.9.12 >= 0.9.12 
    
    Description
    ===========
    
    Multiple vulnerabilities have been discovered in LibVNCServer. Please
    review the CVE identifiers referenced below for details.
    
    Impact
    ======
    
    Please review the referenced CVE identifiers for details.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All LibVNCServer users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=net-libs/libvncserver-0.9.12"
    
    References
    ==========
    
    [ 1 ] CVE-2018-20019
          https://nvd.nist.gov/vuln/detail/CVE-2018-20019
    [ 2 ] CVE-2018-20020
          https://nvd.nist.gov/vuln/detail/CVE-2018-20020
    [ 3 ] CVE-2018-20021
          https://nvd.nist.gov/vuln/detail/CVE-2018-20021
    [ 4 ] CVE-2018-20022
          https://nvd.nist.gov/vuln/detail/CVE-2018-20022
    [ 5 ] CVE-2018-20023
          https://nvd.nist.gov/vuln/detail/CVE-2018-20023
    [ 6 ] CVE-2018-20024
          https://nvd.nist.gov/vuln/detail/CVE-2018-20024
    [ 7 ] CVE-2018-7225
          https://nvd.nist.gov/vuln/detail/CVE-2018-7225
    [ 8 ] CVE-2018-7226
          https://nvd.nist.gov/vuln/detail/CVE-2018-7226
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     https://security.gentoo.org/glsa/201908-05
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2019 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    https://creativecommons.org/licenses/by-sa/2.5
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"4","type":"x","order":"1","pct":57.14,"resources":[]},{"id":"88","title":"Should be more technical","votes":"2","type":"x","order":"2","pct":28.57,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"1","type":"x","order":"3","pct":14.29,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.