Gentoo: GLSA-201910-01: PHP: Arbitrary code execution

    Date25 Oct 2019
    CategoryGentoo
    1352
    Posted ByLinuxSecurity Advisories
    A vulnerability in PHP might allow an attacker to execute arbitrary code.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 201910-01
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                               https://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: High
        Title: PHP: Arbitrary code execution
         Date: October 25, 2019
         Bugs: #698452
           ID: 201910-01
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    A vulnerability in PHP might allow an attacker to execute arbitrary
    code.
    
    Background
    ==========
    
    PHP is an open source general-purpose scripting language that is
    especially suited for web development.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  dev-lang/php                 < 7.1.33                  >= 7.1.33
                                      < 7.2.24                  >= 7.2.24
                                      < 7.3.11                  >= 7.3.11
    
    Description
    ===========
    
    A underflow in env_path_info in PHP-FPM under certain configurations
    can be exploited to gain remote code execution.
    
    Impact
    ======
    
    A remote attacker, by sending special crafted HTTP requests, could
    possibly execute arbitrary code with the privileges of the process, or
    cause a Denial of Service condition.
    
    Workaround
    ==========
    
    If patching is not feasible, the suggested workaround is to include
    checks to verify whether or not a file exists before passing to PHP.
    
    Resolution
    ==========
    
    All PHP 7.1 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-7.1.33"
    
    All PHP 7.2 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-7.2.24"
    
    All PHP 7.3 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-7.3.11"
    
    References
    ==========
    
    [ 1 ] CVE-2019-11043
          https://nvd.nist.gov/vuln/detail/CVE-2019-11043
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     https://security.gentoo.org/glsa/201910-01
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2019 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    https://creativecommons.org/licenses/by-sa/2.5
    
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"65","type":"x","order":"1","pct":57.52,"resources":[]},{"id":"88","title":"Should be more technical","votes":"15","type":"x","order":"2","pct":13.27,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"33","type":"x","order":"3","pct":29.2,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.