Gentoo: GLSA-202003-57: PHP: Multiple vulnerabilities

    Date26 Mar 2020
    193
    Posted ByLinuxSecurity Advisories
    Multiple vulnerabilities have been found in PHP, the worst of which could result in the execution of arbitrary shell commands.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 202003-57
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                               https://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: High
        Title: PHP: Multiple vulnerabilities
         Date: March 26, 2020
         Bugs: #671872, #706168, #710304, #713484
           ID: 202003-57
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple vulnerabilities have been found in PHP, the worst of which
    could result in the execution of arbitrary shell commands.
    
    Background
    ==========
    
    PHP is an open source general-purpose scripting language that is
    especially suited for web development.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  dev-lang/php                 < 7.4.4                  *>= 7.2.29
                                                               *>= 7.3.16
                                                                *>= 7.4.4
    
    Description
    ===========
    
    Multiple vulnerabilities have been discovered in PHP. Please review the
    CVE identifiers referenced below for details.
    
    Impact
    ======
    
    An attacker could possibly execute arbitrary shell commands, cause a
    Denial of Service condition or obtain sensitive information.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All PHP 7.2.x users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-7.2.29"
    
    All PHP 7.3.x users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-7.3.16"
    
    All PHP 7.4.x users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-7.4.4"
    
    References
    ==========
    
    [ 1 ] CVE-2018-19518
          https://nvd.nist.gov/vuln/detail/CVE-2018-19518
    [ 2 ] CVE-2020-7059
          https://nvd.nist.gov/vuln/detail/CVE-2020-7059
    [ 3 ] CVE-2020-7060
          https://nvd.nist.gov/vuln/detail/CVE-2020-7060
    [ 4 ] CVE-2020-7061
          https://nvd.nist.gov/vuln/detail/CVE-2020-7061
    [ 5 ] CVE-2020-7062
          https://nvd.nist.gov/vuln/detail/CVE-2020-7062
    [ 6 ] CVE-2020-7063
          https://nvd.nist.gov/vuln/detail/CVE-2020-7063
    [ 7 ] CVE-2020-7064
          https://nvd.nist.gov/vuln/detail/CVE-2020-7064
    [ 8 ] CVE-2020-7065
          https://nvd.nist.gov/vuln/detail/CVE-2020-7065
    [ 9 ] CVE-2020-7066
          https://nvd.nist.gov/vuln/detail/CVE-2020-7066
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     https://security.gentoo.org/glsa/202003-57
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2020 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    https://creativecommons.org/licenses/by-sa/2.5
    
    
    

    LinuxSecurity Poll

    What do you think of the LinuxSecurity Privacy news articles?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/25-what-do-you-think-of-the-linuxsecurity-privacy-news-articles?task=poll.vote&format=json
    25
    radio
    [{"id":"90","title":"Love them!","votes":"48","type":"x","order":"1","pct":88.89,"resources":[]},{"id":"91","title":"I'm indifferent","votes":"4","type":"x","order":"2","pct":7.41,"resources":[]},{"id":"92","title":"Not interested in this topic","votes":"2","type":"x","order":"3","pct":3.7,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.