Gentoo: GLSA-202006-21: Apache Tomcat: Remote code execution

    Date 15 Jun 2020
    73
    Posted By LinuxSecurity Advisories
    A vulnerability has been discovered in Apache Tomcat which could result in the arbitrary execution of code.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 202006-21
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                               https://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: Normal
        Title: Apache Tomcat: Remote code execution
         Date: June 15, 2020
         Bugs: #724344
           ID: 202006-21
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    A vulnerability has been discovered in Apache Tomcat which could result
    in the arbitrary execution of code.
    
    Background
    ==========
    
    Apache Tomcat is a Servlet-3.0/JSP-2.2 Container.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  www-servers/tomcat         < 7.0.104:7              >= 7.0.104:7 
                                    < 8.5.55:8.5            >= 8.5.55:8.5 
    
    Description
    ===========
    
    Apache Tomcat improperly handles deserialization of files under
    specific circumstances.
    
    Impact
    ======
    
    A remote attacker could possibly execute arbitrary code with the
    privileges of the process, or cause a Denial of Service condition.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All Apache Tomcat 7.x users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=www-servers/tomcat-7.0.104"
    
    All Apache Tomcat 8.x users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=www-servers/tomcat-8.5.55"
    
    References
    ==========
    
    [ 1 ] CVE-2020-9484
          https://nvd.nist.gov/vuln/detail/CVE-2020-9484
    [ 2 ] Upstream advisory (7)
          https://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.104
    [ 3 ] Upstream advisory (8.5)
          https://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.5.55
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     https://security.gentoo.org/glsa/202006-21
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2020 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    https://creativecommons.org/licenses/by-sa/2.5
    

    LinuxSecurity Poll

    Are you considering making the switch to Purism's new Librem 14 Linux laptop to improve your security and privacy online?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/31-are-you-considering-making-the-switch-to-purism-s-new-librem-14-linux-laptop-to-improve-your-security-and-privacy-online?task=poll.vote&format=json
    31
    radio
    [{"id":"109","title":"Yes - the hardware kill switches and default ad blocking\/tracking protection sold me on it.","votes":"3","type":"x","order":"1","pct":37.5,"resources":[]},{"id":"110","title":"Not sure yet - I need to do more research.","votes":"4","type":"x","order":"2","pct":50,"resources":[]},{"id":"111","title":"No - I'm satisfied with my current laptop and have no security\/privacy concerns.","votes":"1","type":"x","order":"3","pct":12.5,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.