Gentoo: GLSA-202007-61: WebKitGTK+: Multiple vulnerabilities

    Date 31 Jul 2020
    72
    Posted By LinuxSecurity Advisories
    Multiple vulnerabilities have been found in WebKitGTK+, the worst of which could result in the arbitrary execution of code.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 202007-61
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                               https://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: Normal
        Title: WebKitGTK+: Multiple vulnerabilities
         Date: July 31, 2020
         Bugs: #734584
           ID: 202007-61
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple vulnerabilities have been found in WebKitGTK+, the worst of
    which could result in the arbitrary execution of code.
    
    Background
    ==========
    
    WebKitGTK+ is a full-featured port of the WebKit rendering engine,
    suitable for projects requiring any kind of web integration, from
    hybrid HTML/CSS applications to full-fledged web browsers.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  net-libs/webkit-gtk          < 2.28.4                  >= 2.28.4
    
    Description
    ===========
    
    Multiple vulnerabilities have been discovered in WebKitGTK+. Please
    review the CVE identifiers referenced below for details.
    
    Impact
    ======
    
    Please review the referenced CVE identifiers for details.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All WebKitGTK+ users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=net-libs/webkit-gtk-2.28.4"
    
    References
    ==========
    
    [ 1 ] CVE-2020-9862
          https://nvd.nist.gov/vuln/detail/CVE-2020-9862
    [ 2 ] CVE-2020-9893
          https://nvd.nist.gov/vuln/detail/CVE-2020-9893
    [ 3 ] CVE-2020-9894
          https://nvd.nist.gov/vuln/detail/CVE-2020-9894
    [ 4 ] CVE-2020-9895
          https://nvd.nist.gov/vuln/detail/CVE-2020-9895
    [ 5 ] CVE-2020-9915
          https://nvd.nist.gov/vuln/detail/CVE-2020-9915
    [ 6 ] CVE-2020-9925
          https://nvd.nist.gov/vuln/detail/CVE-2020-9925
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     https://security.gentoo.org/glsa/202007-61
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2020 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    https://creativecommons.org/licenses/by-sa/2.5
    

    LinuxSecurity Poll

    Are you planning to use the 1Password password manager now that it is available to Linux users?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/35-are-you-planning-to-use-the-1password-password-manager-now-that-it-is-available-to-linux-users?task=poll.vote&format=json
    35
    radio
    [{"id":"122","title":"Yes","votes":"1","type":"x","order":"1","pct":20,"resources":[]},{"id":"123","title":"No ","votes":"3","type":"x","order":"2","pct":60,"resources":[]},{"id":"124","title":"Not sure at the moment","votes":"1","type":"x","order":"3","pct":20,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.