- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202012-16
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Low
     Title: PHP: Multiple vulnerabilities
      Date: December 23, 2020
      Bugs: #711140, #745993, #756775
        ID: 202012-16

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in PHP, the worst of which
could result in a Denial of Service condition.

Background
==========

PHP is an open source general-purpose scripting language that is
especially suited for web development.

Affected packages
=================

     -------------------------------------------------------------------
      Package              /     Vulnerable     /            Unaffected
     -------------------------------------------------------------------
   1  dev-lang/php                 < 8.0.0            >= 7.2.34-r1:7.2
                                                         >= 7.3.25:7.3
                                                         >= 7.4.13:7.4

Description
===========

Multiple vulnerabilities have been discovered in PHP. Please review the
CVE identifiers and change log referenced below for details.

Impact
======

An attacker could cause a Denial of Service condition or obtain
sensitive information.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PHP 7.2.x users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-lang/php-7.2.34-r1:7.2"

All PHP 7.3.x users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-lang/php-7.3.25:7.3"

All PHP 7.4.x users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-lang/php-7.4.13:7.4"

References
==========

[ 1 ] CVE-2020-7069
       https://nvd.nist.gov/vuln/detail/CVE-2020-7069
[ 2 ] CVE-2020-7070
       https://nvd.nist.gov/vuln/detail/CVE-2020-7070
[ 3 ] PHP 7.4.13 Change Log
       https://www.php.net/ChangeLog-7.php#7.4.13

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/202012-16

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5