- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202101-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Mozilla Firefox: Remote code execution
     Date: January 10, 2021
     Bugs: #764161
       ID: 202101-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A use-after-free in Mozilla Firefox's SCTP handling may allow remote
code execution.

Background
==========

Mozilla Firefox is a popular open-source web browser from the Mozilla
project.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  www-client/firefox           < 84.0.2          >= 78.6.1:0/esr78
                                                            >= 84.0.2
  2  www-client/firefox-bin       < 84.0.2          >= 78.6.1:0/esr78
                                                            >= 84.0.2
    -------------------------------------------------------------------
     2 affected packages

Description
===========

A use-after-free bug was discovered in Mozilla Firefox's handling of
SCTP.

Impact
======

A remote attacker could possibly execute arbitrary code with the
privileges of the process, or cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Firefox ESR users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot -v ">=www-client/firefox-78.6.1:0/esr78"

All Firefox ESR binary users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot -v ">=www-client/firefox-bin-78.6.1:0/esr78"

All Firefox users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-client/firefox-84.0.2"

All Firefox binary users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-client/firefox-bin-84.0.2"

References
==========

[ 1 ] CVE-2020-16044
      https://nvd.nist.gov/vuln/detail/CVE-2020-16044
[ 2 ] MFSA-2021-01
      https://www.mozilla.org/en-US/security/advisories/mfsa2021-01/

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202101-04

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5