- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202101-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: NodeJS: Multiple vulnerabilities
     Date: January 11, 2021
     Bugs: #726836, #731654, #742893, #754942, #763588
       ID: 202101-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in NodeJS, the worst of which
could result in the arbitrary execution of code.

Background
==========

Node.js is a JavaScript runtime built on Chrome’s V8 JavaScript engine.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  net-libs/nodejs              < 15.5.1            >= 12.20.1:0/12
                                                      >= 14.15.1:0/14
                                                       >= 15.5.1:0/15

Description
===========

Multiple vulnerabilities have been discovered in NodeJS. Please review
the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All NodeJS 15 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-libs/nodejs-15.5.1"

All NodeJS 14 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-libs/nodejs-14.15.1"

References
==========

[ 1 ] CVE-2020-15095
      https://nvd.nist.gov/vuln/detail/CVE-2020-15095
[ 2 ] CVE-2020-8172
      https://nvd.nist.gov/vuln/detail/CVE-2020-8172
[ 3 ] CVE-2020-8174
      https://nvd.nist.gov/vuln/detail/CVE-2020-8174
[ 4 ] CVE-2020-8201
      https://nvd.nist.gov/vuln/detail/CVE-2020-8201
[ 5 ] CVE-2020-8251
      https://nvd.nist.gov/vuln/detail/CVE-2020-8251
[ 6 ] CVE-2020-8265
      https://nvd.nist.gov/vuln/detail/CVE-2020-8265
[ 7 ] CVE-2020-8277
      https://nvd.nist.gov/vuln/detail/CVE-2020-8277
[ 8 ] CVE-2020-8287
      https://nvd.nist.gov/vuln/detail/CVE-2020-8287

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202101-07

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5