Linux Security
Linux Security
Linux Security

Gentoo: GLSA-202101-11: Zabbix: Root privilege escalation

Date 21 Jan 2021
327
Posted By LinuxSecurity Advisories
Multiple vulnerabilities were discovered in Gentoo's ebuild for Zabbix which could lead to root privilege escalation.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202101-11
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Zabbix: Root privilege escalation
     Date: January 21, 2021
     Bugs: #629882, #629884
       ID: 202101-11

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities were discovered in Gentoo's ebuild for Zabbix
which could lead to root privilege escalation.

Background
==========

Zabbix is software for monitoring applications, networks, and servers.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  net-analyzer/zabbix          < 4.4.6             >= 3.0.30:0/3.0
                                                      >= 4.0.18:0/4.0

Description
===========

It was discovered that Gentoo's Zabbix ebuild did not properly set
permissions or placed the pid file in an unsafe directory.

Impact
======

A local attacker could escalate privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Zabbix 3.0.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot -v ">=net-analyzer/zabbix-3.0.30:0/3.0"

All Zabbix  4.0.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot -v ">=net-analyzer/zabbix-4.0.18:0/4.0"

All other Zabbix users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-analyzer/zabbix-4.4.6"

References
==========


Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202101-11

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Advisories

LinuxSecurity Poll

How frequently do you patch/update your system?

No answer selected. Please try again.
Please select either existing option or enter your own, however not both.
Please select minimum 0 answer(s) and maximum 3 answer(s).
/main-polls/52-how-frequently-do-you-patch-update-your-system?task=poll.vote&format=json
52
radio
[{"id":"179","title":"As soon as patches\/updates are released - I track advisories for my distro(s) diligently","votes":"66","type":"x","order":"1","pct":75.86,"resources":[]},{"id":"180","title":"Every so often, when I think of it","votes":"14","type":"x","order":"2","pct":16.09,"resources":[]},{"id":"181","title":"Hardly ever","votes":"7","type":"x","order":"3","pct":8.05,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350

Please vote first in order to view vote results.

VOTE ON THE POLL PAGE


VIEW MORE POLLS

bottom 200

Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript![ ? ]

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.