Gentoo: GLSA-202104-05: GRUB: Multiple vulnerabilities | LinuxSecur...

Advisories

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202104-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: GRUB: Multiple vulnerabilities
      Date: April 30, 2021
      Bugs: #734654, #773991
        ID: 202104-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in GRUB, the worst might allow
for circumvention of UEFI Secure Boot.

Background
==========

GNU GRUB is a multiboot boot loader used by most Linux systems.

Affected packages
=================

     -------------------------------------------------------------------
      Package              /     Vulnerable     /            Unaffected
     -------------------------------------------------------------------
   1  sys-devel/grub              < 2.06_rc1               >= 2.06_rc1

Description
===========

Multiple vulnerabilities have been discovered in GRUB. Please review
the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GRUB users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=sys-devel/grub-2.06_rc1"

After upgrading, make sure to run the grub-install command with options
appropriate for your system. See the GRUB Quick Start guide in the
references below for examples. Your system will be vulnerable until
this action is performed.

References
==========

[  1 ] CVE-2020-10713
        https://nvd.nist.gov/vuln/detail/CVE-2020-10713
[  2 ] CVE-2020-14308
        https://nvd.nist.gov/vuln/detail/CVE-2020-14308
[  3 ] CVE-2020-14309
        https://nvd.nist.gov/vuln/detail/CVE-2020-14309
[  4 ] CVE-2020-14310
        https://nvd.nist.gov/vuln/detail/CVE-2020-14310
[  5 ] CVE-2020-14311
        https://nvd.nist.gov/vuln/detail/CVE-2020-14311
[  6 ] CVE-2020-14372
        https://nvd.nist.gov/vuln/detail/CVE-2020-14372
[  7 ] CVE-2020-15705
        https://nvd.nist.gov/vuln/detail/CVE-2020-15705
[  8 ] CVE-2020-15706
        https://nvd.nist.gov/vuln/detail/CVE-2020-15706
[  9 ] CVE-2020-15707
        https://nvd.nist.gov/vuln/detail/CVE-2020-15707
[ 10 ] CVE-2020-25632
        https://nvd.nist.gov/vuln/detail/CVE-2020-25632
[ 11 ] CVE-2020-25647
        https://nvd.nist.gov/vuln/detail/CVE-2020-25647
[ 12 ] CVE-2020-27749
        https://nvd.nist.gov/vuln/detail/CVE-2020-27749
[ 13 ] CVE-2020-27779
        https://nvd.nist.gov/vuln/detail/CVE-2020-27779
[ 14 ] CVE-2021-20225
        https://nvd.nist.gov/vuln/detail/CVE-2021-20225
[ 15 ] CVE-2021-20233
        https://nvd.nist.gov/vuln/detail/CVE-2021-20233
[ 16 ] GRUB Quick Start guide
        https://wiki.gentoo.org/wiki/GRUB2_Quick_Start

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/202104-05

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202104-05: GRUB: Multiple vulnerabilities

Summary

Multiple vulnerabilities have been discovered in GRUB. Please review the CVE identifiers referenced below for details.

Resolution

All GRUB users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=sys-devel/grub-2.06_rc1"
After upgrading, make sure to run the grub-install command with options appropriate for your system. See the GRUB Quick Start guide in the references below for examples. Your system will be vulnerable until this action is performed.

References

[ 1 ] CVE-2020-10713 https://nvd.nist.gov/vuln/detail/CVE-2020-10713 [ 2 ] CVE-2020-14308 https://nvd.nist.gov/vuln/detail/CVE-2020-14308 [ 3 ] CVE-2020-14309 https://nvd.nist.gov/vuln/detail/CVE-2020-14309 [ 4 ] CVE-2020-14310 https://nvd.nist.gov/vuln/detail/CVE-2020-14310 [ 5 ] CVE-2020-14311 https://nvd.nist.gov/vuln/detail/CVE-2020-14311 [ 6 ] CVE-2020-14372 https://nvd.nist.gov/vuln/detail/CVE-2020-14372 [ 7 ] CVE-2020-15705 https://nvd.nist.gov/vuln/detail/CVE-2020-15705 [ 8 ] CVE-2020-15706 https://nvd.nist.gov/vuln/detail/CVE-2020-15706 [ 9 ] CVE-2020-15707 https://nvd.nist.gov/vuln/detail/CVE-2020-15707 [ 10 ] CVE-2020-25632 https://nvd.nist.gov/vuln/detail/CVE-2020-25632 [ 11 ] CVE-2020-25647 https://nvd.nist.gov/vuln/detail/CVE-2020-25647 [ 12 ] CVE-2020-27749 https://nvd.nist.gov/vuln/detail/CVE-2020-27749 [ 13 ] CVE-2020-27779 https://nvd.nist.gov/vuln/detail/CVE-2020-27779 [ 14 ] CVE-2021-20225 https://nvd.nist.gov/vuln/detail/CVE-2021-20225 [ 15 ] CVE-2021-20233 https://nvd.nist.gov/vuln/detail/CVE-2021-20233 [ 16 ] GRUB Quick Start guide https://wiki.gentoo.org/wiki/GRUB2_Quick_Start

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202104-05

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Normal
Title: GRUB: Multiple vulnerabilities
Issued Date: April 30, 2021
Bugs: #734654, #773991
ID: 202104-05

Synopsis

Multiple vulnerabilities have been found in GRUB, the worst might allow for circumvention of UEFI Secure Boot.

Background

GNU GRUB is a multiboot boot loader used by most Linux systems.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 sys-devel/grub < 2.06_rc1 >= 2.06_rc1

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.