Gentoo: GLSA-202105-08: ICU: Multiple vulnerabilities

Advisories

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202105-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Low
     Title: ICU: Multiple vulnerabilities
      Date: May 26, 2021
      Bugs: #755704
        ID: 202105-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in ICU, the worst of which
could cause a Denial of Service condition.

Background
==========

ICU is a mature, widely used set of C/C++ and Java libraries providing
Unicode and Globalization support for software applications.

Affected packages
=================

     -------------------------------------------------------------------
      Package              /     Vulnerable     /            Unaffected
     -------------------------------------------------------------------
   1  dev-libs/icu                  < 68.2                     >= 68.2

Description
===========

Multiple vulnerabilities have been discovered in ICU. Please review the
upstream bugs referenced below for details.

Impact
======

Remote attackers could cause a Denial of Service condition or possibly
have other unspecified impacts via unspecified vectors.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All ICU users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-libs/icu-68.2"

References
==========

[ 1 ] Chromium Change-Id Iad839ac77d487d5e1b396bcdbc29bc7cd58a7ef8
 
https://chromium-review.googlesource.com/q/Iad839ac77d487d5e1b396bcdbc29bc7cd58a7ef8
[ 2 ] ICU-21383
       https://unicode-org.atlassian.net/browse/ICU-21383
[ 3 ] ICU-21385
       https://unicode-org.atlassian.net/browse/ICU-21385

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/202105-08

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202105-08: ICU: Multiple vulnerabilities

Summary

Multiple vulnerabilities have been discovered in ICU. Please review the upstream bugs referenced below for details.

Resolution

All ICU users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-libs/icu-68.2"

References

[ 1 ] Chromium Change-Id Iad839ac77d487d5e1b396bcdbc29bc7cd58a7ef8
https://chromium-review.googlesource.com/q/Iad839ac77d487d5e1b396bcdbc29bc7cd58a7ef8 [ 2 ] ICU-21383 https://unicode-org.atlassian.net/browse/ICU-21383 [ 3 ] ICU-21385 https://unicode-org.atlassian.net/browse/ICU-21385

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202105-08

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Low
Title: ICU: Multiple vulnerabilities
Issued Date: May 26, 2021
Bugs: #755704
ID: 202105-08

Synopsis

Multiple vulnerabilities have been found in ICU, the worst of which could cause a Denial of Service condition.

Background

ICU is a mature, widely used set of C/C++ and Java libraries providing Unicode and Globalization support for software applications.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-libs/icu < 68.2 >= 68.2

Impact

Remote attackers could cause a Denial of Service condition or possibly have other unspecified impacts via unspecified vectors.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.